Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155281 - If selinux & Reuserfs used, initscripts & slocate fail
Summary: If selinux & Reuserfs used, initscripts & slocate fail
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 19:08 UTC by Karen Pease
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 14:22:42 UTC


Attachments (Terms of Use)

Description Karen Pease 2005-04-18 19:08:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
If the user chooses "linux reiserfs" as their arguments for starting the installation, selinux should default to 0 (as if they had typed "linux reiserfs selinux=0").  If you don't, they'll get through the installation thinking everything was okay, and then get struck by the fact that one of the most important packages - initscripts - failed to install (along with slocate) because the pre scriptlets failed.  Other less critical errors will occur in installation of other packages.  Reiserfs and selinux, until these bugs are fixed, should be viewed as incompatible.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Startup with "linux reiserfs"
2. Choose the defaults when asked about selinux (i.e., leave it on)
3. Try to boot

  

Additional info:

Comment 1 Chris Lumens 2005-04-25 14:22:42 UTC
reiserfs is completely unsupported.

Comment 2 Karen Pease 2005-04-25 15:59:23 UTC
Understood.  However, it *is* an option, and it would seem that it would take 
just as much effort to remove it as an option (which you might as well if it 
doesn't work from a normal install) as it would to pass selinux=0 when 
reiserfs is chosen.  Knowingly leaving broken options without even a notice is 
just bad form. 
 

Comment 3 Paul Nasrat 2005-04-25 16:42:20 UTC
It's documented in fsset.py:

       # this is totally, 100% unsupported.  Boot with "linux reiserfs"
        # at the boot: prompt will let you make new reiserfs filesystems
        # in the installer.  Bugs filed when you use this will be closed
        # WONTFIX.

However if you have time to make a patch that's more likely to be looked at.

Comment 4 Karen Pease 2005-04-25 17:51:23 UTC
Sure - here's my patch: change those lines in fsset.py to read: 
 
# this is totally, 100% unsupported.  Boot with "linux reiserfs selinux=0" 
# at the boot: prompt will let you make a new reiserfs filesystem 
# in the installer.  Bugs filed when you use this will be closed 
# WONTFIX 
 
Then it's documented. 
 


Note You need to log in before you can comment on or make changes to this bug.