Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155274 - Using reiserfs, grub gives error 24 on startup (fatal)
Summary: Using reiserfs, grub gives error 24 on startup (fatal)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 18:53 UTC by Karen Pease
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 19:05:45 UTC


Attachments (Terms of Use)

Description Karen Pease 2005-04-18 18:53:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
If you run anaconda with reiserfs, the installation gives no errors relaive to this, but when you first boot, it will lock up with Error 24.  After several tries, I discovered a workaround: after you get the error, reboot in rescue mode, move your vmlinuz and initrd files from /boot to elsewhere, copy (not move) them back, and delete the originals.  I.e., you want to force the files to get re-written.  It should work after this (at least, it did for me, twice).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the installer with commandline: linux reiserfs
2. Install
3. Reboot
 

Additional info:

Comment 1 Chris Lumens 2005-04-18 19:05:45 UTC
reiserfs is completely unsupported.

Comment 2 Zaphod Beeblebrox 2005-06-23 01:03:18 UTC
Unacceptable!! Reiserfs is supported in the 2.6 kernel and it's a boot option
for the installer. Reiserfs has worked flawlessly for me since the days of
Redhat 9, so why the trouble all of a sudden? Seems like it wouldn't be that
difficult to fix the anaconda problems.


Note You need to log in before you can comment on or make changes to this bug.