Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155258 - xircom_cb much slower than xircom_tulip_cb
Summary: xircom_cb much slower than xircom_tulip_cb
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 16:55 UTC by Chris Tracy
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-26 07:29:04 UTC


Attachments (Terms of Use)

Description Chris Tracy 2005-04-18 16:55:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.10 (X11; Linux i686; U;) Gecko/20030412

Description of problem:
I recently upgraded my old Inspiron 5000 from FC1 to FC3.  Since the system
doesn't have built-in Ethernet, I've had a Xircom Cardbus Ethernet PCMCIA card
in it for years.  In FC3, the card uses the xircom_cb driver.

After the upgrade, I discovered that my network throughput had dropped significantly.  Whereas in 2.4.x, I could wget from another system on the LAN at
8-9MB/s (64-72Mbit) in FC3 I'm getting 2-3MB/s (16-24Mbit) from the same system
downloading the same test file.  Out of curiousity, I installed vanilla 2.6.11.7
and observed the same issue using the xircom_cb driver.  However, switching over
to the xircom_tulip_cb driver, my throughput is right back where it was in 2.4.x.

I've reported the issue to the linux-pcmcia list at infradead, but wanted to ask 
that you consider enabling the xircom_tulip_cb module in a future kernel update
to address this issue.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 on an Inspiron 5000 with a Xircom Cardbus Ethernet PCMCIA card
2. Test throughput
  

Actual Results:  Throughput is much lower than it was in FC1.  (2.4.x)

Expected Results:  Throughput should be as good as 2.4.x.  (xircom_tulip_cb module should be
installed for now as a fallback)

Additional info:

Comment 1 Dave Jones 2005-07-15 20:10:17 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Chris Tracy 2005-08-13 17:19:40 UTC
Unfortunately, this system is now in production using a different card, so I am
currently unable to test the fix in the new kernel.  I don't know that I'll have
an opportunity in the near future, so if you'd like to close the bug for now, I
have no objection.


Note You need to log in before you can comment on or make changes to this bug.