Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155256 - /var/log/lastlog from setup conflicts with util-linux
Summary: /var/log/lastlog from setup conflicts with util-linux
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
: 166959 (view as bug list)
Depends On:
Blocks: FC4Blocker FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-18 16:47 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version: 4.4.1-21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-22 12:26:22 UTC


Attachments (Terms of Use)
Ignore %ghost and %ghost file conflicts (deleted)
2005-04-19 15:55 UTC, Paul Nasrat
no flags Details | Diff
setup vs util-linux rpmfi (deleted)
2005-06-16 14:53 UTC, Paul Nasrat
no flags Details

Description Robert Scheck 2005-04-18 16:47:12 UTC
Description of problem:
Preparing...                ########################################### [100%]
        file /var/log/lastlog from install of setup-2.5.41-1 conflicts with 
file from package util-linux-2.12p-7

Version-Release number of selected component (if applicable):
setup-2.5.41-1

How reproducible:
Everytime.

Expected results:
No conflict.

Comment 1 Bill Nottingham 2005-04-18 16:51:03 UTC
Should be fixed in 2.5.42-1.

Comment 2 Robert Scheck 2005-04-19 11:57:45 UTC
No, it isn't; reopening :-(

Preparing...                ########################################### [100%]
        file /var/log/lastlog from install of setup-2.5.42-1 conflicts with file from package util-linux-2.12p-7

Bill, couldn't we remove owning /var/log/lastlog from setup package but require 
latest util-linux for example?

Comment 3 Bill Nottingham 2005-04-19 15:15:06 UTC
No, beause if util-linux isn't installed first, it will get removed on update.

util-linux.spec has:
%ghost %attr(0400,root,root) %verify(not md5 size mtime) /var/log/lastlog

setup.spec has:
%ghost %attr(0400,root,root) %verify(not md5 size mtime) /var/log/lastlog

Not sure what else to do here...

Comment 4 Paul Nasrat 2005-04-19 15:55:39 UTC
Created attachment 113368 [details]
Ignore %ghost and %ghost file conflicts

We could be skipping %ghost file conflicts if both packages mark the file as
%ghost

The patch above addresses strictly %ghost and %ghost behaviour.

Comment 5 Robert Scheck 2005-05-20 17:33:10 UTC
Using current Rawhide, installing of the setup package is possible without any 
problem or conflict. Can somebody confirm this?

Comment 6 Roozbeh Pournader 2005-06-09 17:01:26 UTC
The bug is still there in FC4.

Comment 7 Robert Scheck 2005-06-09 17:30:07 UTC
Really?! Reopening as FC4Blocker until somebody of Red Hat says the opposite...

Comment 8 Karel Zak 2005-06-16 13:19:22 UTC
I can confirm it:
  # rpm -U util-linux-2.12p-9.4.i386.rpm
        file /var/log/lastlog from install of util-linux-2.12p-9.4 conflicts
        with file from package setup-2.5.44-1

  # rpm -q rpm
  rpm-4.4.1-21

Bill's comment #3 is true. There's %ghost in both packages.

%post in util-linux:
  touch /var/log/lastlog
  chown root:root /var/log/lastlog
  chmod 0400 /var/log/lastlog


Comment 9 Jeff Johnson 2005-06-16 14:14:03 UTC
And *WHY* is this problem being reported against rpm?

Skipping %ghost file conflicts is just the tip of an iceberg ...

Comment 10 Paul Nasrat 2005-06-16 14:53:46 UTC
Created attachment 115544 [details]
setup vs util-linux rpmfi

Comment 11 Robert Scheck 2005-09-10 10:50:32 UTC
Paul, can we *please* get rid of this problem very soon? It's very annoying and 
absolutely unnecessary! So the package setup avoids update of util-linux and the 
other way round!

IMHO there are two possibilities:
a) The Red Hat maintainers do fine RPM packaging (the way jbj prefers)
b) Or we're using your workaround/hack from comment #4

Comment 12 Jeff Johnson 2005-11-14 03:34:44 UTC
This is a util-linux or setup, not an rpm, problem. rpm has flat zippo to say
about what packages own what files.

Reassigning to util-linux ...

Comment 17 Karel Zak 2005-11-28 13:51:14 UTC
Paul, what's up with rpm-4.4.3?

Comment 18 Paul Nasrat 2005-11-28 18:23:42 UTC
*** Bug 166959 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.