Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155254 - Rebuilding of httpd ends with I/O error of xmlto
Summary: Rebuilding of httpd ends with I/O error of xmlto
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 16:41 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 12:29:59 UTC


Attachments (Terms of Use)

Description Robert Scheck 2005-04-18 16:41:29 UTC
Description of problem:
[...]
+ xmlto -x /usr/src/redhat/SOURCES/html.xsl html-nochunks migration.xml
I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl"
compilation error: file /usr/src/redhat/SOURCES/html.xsl line 12 element import
xsl:import : unable to load http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl
cp: cannot stat `/tmp/xmlto.C23386/migration.proc': No such file or directory

The machine has direct Internet access, w3m/wget <file> also works.

Version-Release number of selected component (if applicable):
httpd-2.0.54-3
xmlto-0.0.18-6

How reproducible; Steps to Reproduce:
Everytime, trying to rebuild it.

Actual results:
Error message.

Expected results:
Rebuilding.

Comment 1 Joe Orton 2005-04-19 08:14:08 UTC
Hmmm, I thought we used tricks to use the local copies of docbook-xsl, though
perhaps since httpd uses a custom stylesheet which does:

<xsl:import
href="http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl"/>

these don't work.  Tim, any way I can make this work without going to the network?

Comment 2 Tim Waugh 2005-04-19 12:29:59 UTC
That should work fine, since we resolve addresses that start
"http://docbook.sourceforge.net/release/xsl/current" to directories based at
/usr/share/sgml/docbook/xsl-stylesheets-{version} -- see /etc/xml/catalog for
the gory details.

In fact, a build of httpd-2.0.54-4 on rawhide/i386 works fine for me.  Sounds
like the reporter doesn't have docbook-style-xsl installed correctly.


Note You need to log in before you can comment on or make changes to this bug.