Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155243 - Deleting packages causes 500 Error
Summary: Deleting packages causes 500 Error
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: rhn400
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL: https://rhn.webdev.redhat.com/network...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 14:28 UTC by John Wregglesworth
Modified: 2007-04-18 17:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 16:57:40 UTC


Attachments (Terms of Use)

Description John Wregglesworth 2005-04-18 14:28:39 UTC
Description of problem: I got a 500 error when I went to delete some packages
that I had pushed to webdev. This was on the Manage Software Packages page.
Traceback to follow.

Comment 1 John Wregglesworth 2005-04-18 14:29:27 UTC
Here's the promised traceback:

The following exception occured while executing this request:
 GET
/network/software/packages/manage/delete_confirm.pxt?set_label=deletable_package_list
HTTP/1.1 (from browser)
 /network/software/packages/manage/delete_confirm.pxt (from Apache)

Date:
  Mon Apr 18 10:12:54 2005

Headers:
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Cookie: rh_auth_token=3905114:1113833486x35d8f1c456c9c5b458dfd96c5883d099;
pxt-session-cookie=16xb19a982d61c34fc37f1fb517c7e91947
  Host: rlx-3-18.rhndev.redhat.com
  Keep-Alive: 300
  Referer:
https://rlx-3-18.rhndev.redhat.com/network/software/packages/manage/index.pxt
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

Form variables:
  set_label => deletable_package_list

User Information:
  User admin (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: Provider for 'package_ids_in_set' failed to provide column 'NVRE'
Row data:  $VAR1 = {
          'ID' => '3034',
          'NVREA' => 'apg-2.2.3-3.1.fc2.dag.i386'
        };

  Sniglets::ListView::List
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Sniglets/ListView/List.pm
1049 RHN::Exception::throw
  Sniglets::Lists
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Sniglets/Lists.pm 117
Sniglets::ListView::List::render
  PXT::Parser
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/PXT/Parser.pm 160
Sniglets::Lists::listview
  PXT::Parser
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/PXT/Parser.pm 72
PXT::Parser::expand_tag
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/PXT/ApacheHandler.pm 618
PXT::Parser::expand_tags
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/PXT/ApacheHandler.pm 110
PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/PXT/ApacheHandler.pm 110
(eval)
  main /dev/null 0 PXT::ApacheHandler::handler
  main /dev/null 0 (eval)


Comment 2 John Wregglesworth 2005-04-18 14:37:12 UTC
Oops, that traceback was from when I duped the error on a satellite. I'll get
the one from webdev.

Comment 3 John Wregglesworth 2005-04-18 14:39:46 UTC
Webdev traceback:

The following exception occured while executing this request:
 GET
/network/software/packages/manage/delete_confirm.pxt?set_label=deletable_package_list
HTTP/1.1 (from browser)
 /network/software/packages/manage/delete_confirm.pxt (from Apache)

Date:
  Mon Apr 18 10:16:55 2005

Headers:
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: close
  Cookie: rh_auth_token=3905114:1113833815x3bfa061319c0c4be4e4b0dba61eb2440;
pxt-session-cookie=1390876039x8c4079b782b564a32351ff64095b1fd4
  Host: rhnweb.back-webdev.redhat.com
  Referer: https://rhn.webdev.redhat.com/network/software/packages/manage/index.pxt
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0
  Via: 1.1 rhn.webdev.redhat.com
  X-ENV-HTTPS: on
  X-Forwarded-For: 172.16.59.61
  X-Host: rhn.webdev.redhat.com
  X-Proxy-Forwarded-For: 172.16.59.61
  X-Proxy-Forwarded-Host: rhn.webdev.redhat.com
  X-Proxy-Forwarded-Server: rhn.webdev.redhat.com
  X-Replace-Content-Active: 1
  X-Server-Hostname: rhn.webdev.redhat.com

Form variables:
  set_label => deletable_package_list

User Information:
  User wregglej (id 3905114, org_id 4446955)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: Provider for 'package_ids_in_set' failed to provide column 'NVRE'
Row data:  $VAR1 = {
          'NVREA' => 'kernel-smp-2.6.5-7.151.i586',
          'ID' => '302183'
        };

  Sniglets::ListView::List /var/www/lib/Sniglets/ListView/List.pm 1056
RHN::Exception::throw
  Sniglets::Lists /var/www/lib/Sniglets/Lists.pm 117
Sniglets::ListView::List::render
  PXT::Parser /var/svn/rhn-svn/eng/web/modules/pxt/PXT/Parser.pm 160
Sniglets::Lists::listview
  PXT::Parser /var/svn/rhn-svn/eng/web/modules/pxt/PXT/Parser.pm 72
PXT::Parser::expand_tag
  PXT::ApacheHandler /var/svn/rhn-svn/eng/web/modules/pxt/PXT/ApacheHandler.pm
619 PXT::Parser::expand_tags
  PXT::ApacheHandler /var/svn/rhn-svn/eng/web/modules/pxt/PXT/ApacheHandler.pm
110 PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler /var/svn/rhn-svn/eng/web/modules/pxt/PXT/ApacheHandler.pm
110 (eval)
  main /dev/null 0 PXT::ApacheHandler::handler
  main /dev/null 0 (eval) 

Comment 4 Bret McMillan 2005-06-17 16:57:40 UTC

*** This bug has been marked as a duplicate of 150521 ***

Comment 5 Bret McMillan 2005-06-17 17:27:49 UTC

*** This bug has been marked as a duplicate of 158144 ***


Note You need to log in before you can comment on or make changes to this bug.