Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155238 - Internal Compiler Error
Summary: Internal Compiler Error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 13:28 UTC by Bruce Trask
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 13:07:46 UTC


Attachments (Terms of Use)

Description Bruce Trask 2005-04-18 13:28:31 UTC
Description of problem:

The following code causes an internal compiler error.  It word with Comeau and 
gcc 3.2.3

class AClass
{
public:
  void func(unsigned long)
  {
  }

  unsigned long func2()
  {
    return 0;
  }
};

struct Test
{
  typedef unsigned long value_type;
};


template<typename DERIVED>
class Res
{
  
  
  template<
           typename T, 
           void (DERIVED::*funccaller1)(typename T::value_type), 
           typename T::value_type (DERIVED::*funccaller2)()
         >
  class Callbacker
  {
  };

};


int main()
{
  Res<AClass> myRes;
}




g++ testit.cpp -o testit
testit.cpp: In instantiation of `Res<AClass>':
testit.cpp:41:   instantiated from here
testit.cpp:33: internal compiler error: in lookup_member, at
cp/search.c:1296
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc12EJcK.out file, please attach
this to your bugreport.

Compilation exited abnormally with code 1 at Mon Apr 18 09:12:56

g++ --version
g++ (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2005-04-28 13:07:46 UTC
Can't reproduce this with neither gcc-c++-3.4.3-22.fc3 nor 4.0.0-1.


Note You need to log in before you can comment on or make changes to this bug.