Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155237 - no update posiible
Summary: no update posiible
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 13:22 UTC by Martin Welss
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-05 16:29:58 UTC


Attachments (Terms of Use)

Description Martin Welss 2005-04-18 13:22:09 UTC
Description of problem:
in the dialog of updateable packages the forward button is always disabled (btw,
select all doesn't work) no matter how many packages are selected

Version-Release number of selected component (if applicable):


How reproducible

Steps to Reproduce:
1. launch up2date via rhn-applet
2. select pakcages to update
3. forward button is disabled
  
Actual results:


Expected results:


Additional info:

Comment 1 Connor Lund 2005-04-20 03:51:57 UTC
I found an newer verson of up2date and installed: "up2date-4.4.14-2.i386.rpm"...
This did not fix the problem either

Comment 2 Connor Lund 2005-04-20 20:13:52 UTC
i did: "up2date --channel --installall".  This opened a GUI where i was able to
download the kernel files (atleast that's how it appeared) --the select all
button worked in this window.  I clicked on the forward button and the rest of
the packages showed up in the window.  The select all button didn't work, but i
selected a few of them, in my terminal window the following message appeared
when I selected the files.  When I clicked on the forward button it tried to
solve the dependencies, but froze.
______________________________________________________________________________
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/checklist.py", line 138, in _key_press_cb
    self._toggle_row (self.focus_row)
  File "/usr/share/rhn/up2date_client/checklist.py", line 134, in _toggle_row
    self.toggled_func(val, row_data)
  File "/usr/share/rhn/up2date_client/gui.py", line 281, in updateSelectedSize
    self.__updateSelectedSizeLabel(sizeLabel, state, rowData)
  File "/usr/share/rhn/up2date_client/gui.py", line 275, in
__updateSelectedSizeLabel
    self.pkgsSelected = self.pkgsSelected + 1
TypeError: unsupported operand type(s) for +: 'instance' and 'int'


Comment 3 John Thacker 2006-10-29 20:28:44 UTC
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.

Comment 4 John Thacker 2006-11-05 16:29:58 UTC
Closing per previous message.


Note You need to log in before you can comment on or make changes to this bug.