Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155236 - thinkpad r40e boot failure with acpi enabled.
Summary: thinkpad r40e boot failure with acpi enabled.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 12:56 UTC by Martin Garton
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 17:56:29 UTC


Attachments (Terms of Use)
makes r40e with bios version 1SET61WW able to boot. (deleted)
2005-04-19 20:45 UTC, Martin Garton
no flags Details | Diff

Description Martin Garton 2005-04-18 12:56:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
linux will not boot unless acpi=off is specified.  Obviously this is undesirable as I would like to at least be able to see battery charge level.

A little testing and a few recompiles to narrow this down showed that setting  "CONFIG_ACPI_PROCESSOR=n" enabled booting and other acpi features worked fine.

Ideally should not have to do this workaround since ACPI idle handler is desirable.



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1240_FC4

How reproducible:
Always

Steps to Reproduce:
1. attempt to boot unmodified rpm kernel.


Actual Results:  freeze during boot. reboot required.


Expected Results:  normal boot.

Additional info:

the kernel gets as far as detecting ide hardware before freezing.

Comment 1 Martin Garton 2005-04-18 13:09:53 UTC
I forgot to mention that this is not a recent regression and so not so high
priority perhaps. It hasn't worked on any of the kernels I tested since the
original FC3 one.


Comment 2 Martin Garton 2005-04-19 20:44:03 UTC
I notice there is already something in
linux-2.6.11/drivers/acpi/processor_idle.c  for "IBM ThinkPad R40e" but it
doesnt apply to my machine because of a differing bios version (mine appears newer)

I tried adding something similar and now the machine boots with the original
.config supplied in the default fedora rpm.

I don't know if this fixes the issue properly. It apparently prevents the
machine going to c2/c3 but at least users can install and run FC on their
machines until it is fixed better.

See attached patch.


Comment 3 Martin Garton 2005-04-19 20:45:35 UTC
Created attachment 113376 [details]
makes r40e with bios version 1SET61WW able to boot.

Comment 4 Dave Jones 2005-04-20 02:24:00 UTC
Thanks, applied to CVS. Will be in tomorrows build.


Comment 5 Martin Garton 2005-04-20 17:56:29 UTC
works fine now using 2.6.11-1.1251_FC4

thanks.



Note You need to log in before you can comment on or make changes to this bug.