Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155233 - Core dumps broken on rhel3u3 / ia64
Summary: Core dumps broken on rhel3u3 / ia64
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 12:01 UTC by Johan Walles
Modified: 2013-03-06 05:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 15:51:38 UTC


Attachments (Terms of Use)

Description Johan Walles 2005-04-18 12:01:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20041013 Firefox/0.9.3 (Ubuntu)

Description of problem:
I'm unable to get a stack trace out of a core file generated on rhel3u3 / ia64.


Version-Release number of selected component (if applicable):
2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. Build this, call the result "crash":
"
void breakage()
{
   volatile int i = *(int*)7;
   (void)i;
}

int main(int argc, char *argv[]) {
   breakage();

   return 0;
}
"

2. ulimit -c unlimited

3. ./crash
Segmentation fault (core dumped)

4. gdb -nx ./crash core.12345

5. bt 5


Actual Results:  (gdb) bt 5
#0  breakage () at crash.c:3
#1  0x200000000007c040 in ?? ()
#2  0x0000000000000000 in ?? ()
#3  0x0000000000000000 in ?? ()
#4  0x0000000000000000 in ?? ()
(More stack frames follow...)
(gdb)

Expected Results:  (gdb) bt 5
#0  breakage () at crash.c:3
#1  0x4000000000000690 in main (argc=1, argv=0x60000fffffffb848) at crash.c:8
(gdb)

Additional info:

Severity high because of data loss when any user land program crashes.

johan@sthqa12:~/src/test$ cat /proc/version
Linux version 2.4.21-20.EL (bhcompile@bullwinkle.build.redhat.com) (gcc version 3.2.3 2 0030502 (Red Hat Linux 3.2.3-42)) #1 SMP Wed Aug 18 20:30:22 EDT 2004

johan@sthqa12:~/src/test$ cat /proc/cpuinfo
processor  : 0
vendor     : GenuineIntel
arch       : IA-64
family     : Itanium 2
model      : 1
revision   : 5
archrev    : 0
features   : branchlong
cpu number : 0
cpu regs   : 4
cpu MHz    : 1500.000000
itc MHz    : 1500.000000
BogoMIPS   : 2239.75

processor  : 1
vendor     : GenuineIntel
arch       : IA-64
family     : Itanium 2
model      : 1
revision   : 5
archrev    : 0
features   : branchlong
cpu number : 0
cpu regs   : 4
cpu MHz    : 1500.000000
itc MHz    : 1500.000000
BogoMIPS   : 2239.75

processor  : 2
vendor     : GenuineIntel
arch       : IA-64
family     : Itanium 2
model      : 1
revision   : 5
archrev    : 0
features   : branchlong
cpu number : 0
cpu regs   : 4
cpu MHz    : 1500.000000
itc MHz    : 1500.000000
BogoMIPS   : 2239.75

processor  : 3
vendor     : GenuineIntel
arch       : IA-64
family     : Itanium 2
model      : 1
revision   : 5
archrev    : 0
features   : branchlong
cpu number : 0
cpu regs   : 4
cpu MHz    : 1500.000000
itc MHz    : 1500.000000
BogoMIPS   : 2239.75

johan@sthqa12:~/src/test$ gdb --version
GNU gdb Red Hat Linux (6.1post-1.20040607.17rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "ia64-redhat-linux-gnu".

Comment 1 Staffan Larsen 2005-04-18 13:11:03 UTC
Same thing with (ie no 'volatile'):

void breakage()
{
   *(int*)0=0;
}

Comment 2 Johan Walles 2005-04-19 06:49:02 UTC
For any BEA folks reading this, this is CR221542.


Comment 3 Jason Baron 2005-04-19 15:51:38 UTC
This test case worked fine for me on the latest RHEL3 bits:

* GNU gdb Red Hat Linux (6.3.0.0-0.30rh)
* kernel - 2.4.21-31.EL

Comment 5 Johan Walles 2005-04-20 06:56:04 UTC
When will the latest RHEL3 bits become part of an update?


Comment 6 Ernie Petrides 2005-04-20 19:30:04 UTC
Hello, Johan.  RHEL3 U5 is currently scheduled for official release on
11-May-2005.  The RHN beta channels have the 2.4.21-31.EL kernel right
now (and will soon get the -32.EL kernel that was respun on Friday).

Jason will determine whether the problem was fixed in U4 or U5.


Comment 7 Johan Walles 2005-04-21 10:14:45 UTC
Another thing, can you confirm that it was an SMP ia64 system that you tried
this on?  Just want to make sure.



Comment 8 Jason Baron 2005-04-21 15:35:31 UTC
yes, i tried this on an smp ia64 system.

Comment 9 Johan Walles 2005-05-09 11:41:18 UTC
Have you been able to repro on an RHEL3u3 system?

It would be good to know whether you can confirm that this has been fixed, or
whether you simply cannot reproduce it (for whatever reason).



Note You need to log in before you can comment on or make changes to this bug.