Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1552327 - "set_fact docker_exec_cmd" assumes there will be mons, but does not use the external list of mons if provided
Summary: "set_fact docker_exec_cmd" assumes there will be mons, but does not use the e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z2
: 3.0
Assignee: leseb
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1553196 (view as bug list)
Depends On:
Blocks: 1548353 1565221 1600697
TreeView+ depends on / blocked
 
Reported: 2018-03-06 23:04 UTC by John Fulton
Modified: 2018-08-13 23:09 UTC (History)
19 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.29-1.el7cp Ubuntu: ceph-ansible_3.0.29-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1565221 (view as bug list)
Environment:
Last Closed: 2018-04-26 17:38:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2495 None None None 2018-04-04 15:53:11 UTC
Red Hat Product Errata RHBA-2018:1259 None None None 2018-04-26 17:39:20 UTC

Description John Fulton 2018-03-06 23:04:14 UTC
While using latest OSP12 and doing a deployment which uses ceph-ansible to deploy an overcloud to use an external ceph cluster as described in documentation [1], the deployment fails on WorkflowTasks_Step2_Execution OS::Mistral::ExternalResource. 

During the ceph-install workflow the enable_ssh_admin task [2] called the tripleo.access.v1.enable_ssh_admin workbook which failed on the task create_admin_via_nova [3]. 

Error may be seen by running the following on the undercloud: 

mistral task-get-result cd02e39d-6505-4e01-b06b-5f7218ae8369| jq . | sed -e 's/\\n/\n/g' -e 's/\\"/"/g'

The output of the above is at:  http://paste.openstack.org/show/693495/



[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html-single/integrating_an_overcloud_with_an_existing_red_hat_ceph_cluster

[2] https://github.com/openstack/tripleo-common/blob/master/workbooks/ceph-ansible.yaml#L56-L60

[3] https://github.com/openstack/tripleo-common/blob/master/workbooks/access.yaml#L89

Comment 18 errata-xmlrpc 2018-04-26 17:38:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1259

Comment 20 Giulio Fidente 2018-08-13 23:09:02 UTC
*** Bug 1553196 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.