Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155225 - firefox-1.0.3-1.4.1 startup failure
Summary: firefox-1.0.3-1.4.1 startup failure
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 08:12 UTC by Warren Togami
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-31 03:35:46 UTC


Attachments (Terms of Use)
firefox-strace.txt (deleted)
2005-04-18 08:14 UTC, Warren Togami
no flags Details
firefox-diff.txt (deleted)
2005-04-18 08:16 UTC, Warren Togami
no flags Details

Description Warren Togami 2005-04-18 08:12:55 UTC
Description of problem:
firefox-1.0.3-1.4.1 totally fails to start the browser if you upgraded from
FC3's firefox-1.0.3-1.3.1.  While this is an unsupported upgrade path, there is
probably a simple package fix to avoid this problem involving file ownership. 
In order to recover the user must totally uninstall firefox before reinstalling
firefox-1.0.3-1.4.1.

Reproduce Procedure:
[root@ibmlaptop lib]# rpm -e firefox
[root@ibmlaptop lib]# rpm -Uvh /tmp/firefox-1.0.3-1.4.1.i386.rpm
Preparing...                ########################################### [100%]
   1:firefox                ########################################### [100%]
[root@ibmlaptop lib]# cp -a firefox-1.0.3/ firefox-1.0.3.el4
[root@ibmlaptop lib]# rpm -Uvh /tmp/firefox-1.0.3-1.3.1.i386.rpm --oldpackage
Preparing...                ########################################### [100%]
   1:firefox                ########################################### [100%]
[root@ibmlaptop lib]# rpm -Uvh /tmp/firefox-1.0.3-1.4.1.i386.rpm
Preparing...                ########################################### [100%]
   1:firefox                ########################################### [100%]

Then run "firefox" as your non-root user.  Attachments next with more details.

Comment 1 Warren Togami 2005-04-18 08:14:19 UTC
Created attachment 113313 [details]
firefox-strace.txt

strace showing where firefox gets stuck during startup.

Comment 2 Warren Togami 2005-04-18 08:16:58 UTC
Created attachment 113314 [details]
firefox-diff.txt

diff -urN /usr/lib/firefox-1.0.3.el4/ /usr/lib/firefox-1.0.3
Former being a clean install of firefox-1.0.3-1.4.1, latter being
firefox-1.0.3-1.4.1 after upgrade from firefox-1.0.3-1.3.1.

Comment 3 Christopher Aillon 2006-10-31 03:35:46 UTC
Going to close since this is a non-supported case and there were no other
reports.  Additionally, this should have gone away with 1.5 since it doesn't do
the registering at install anymore.


Note You need to log in before you can comment on or make changes to this bug.