Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155221 - missing BuildRequires: gcc-c++ rpm-devel elfutils-devel beecrypt-devel
Summary: missing BuildRequires: gcc-c++ rpm-devel elfutils-devel beecrypt-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
: 149643 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 08:00 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.0.4-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 12:46:09 UTC


Attachments (Terms of Use)

Description Marius Andreiana 2005-04-18 08:00:36 UTC
I tried to recompile the php rpm (with oracle support, don't know if it
matters), after I installed all depencies but it gave an error. Here's config.log:

configure:3705: checking how to run the C++ preprocessor
configure:3736: g++ -E  conftest.cc
./configure: line 3737: g++: command not found
configure:3742: $? = 127
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #ifdef __cplusplus
| void exit (int);
| #endif
| /* end confdefs.h.  */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
|                    Syntax error
configure:3736: g++ -E  conftest.cc
./configure: line 3737: g++: command not found
configure:3742: $? = 127
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #ifdef __cplusplus
| void exit (int);
| #endif
| /* end confdefs.h.  */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
|                    Syntax error
configure:3736: /lib/cpp  conftest.cc
cpp: installation problem, cannot exec 'cc1plus': No such file or directory

After installing gcc-c++ got another error:
checking for init_snmp in -lnetsnmp... no
configure: error: SNMP sanity check failed. Please check config.log for more
information.
config.log had:
/usr/bin/ld: cannot find -lrpm

It's required by snmp:
net-snmp-config --libs
-L/usr/lib -lnetsnmp -lcrypto -lrpm -lrpmio -lpopt -lbz2 -lz -lelf -lm
-L/usr/lib/lib -lwrap
(Is rpm-devel really necessary for snmp?)

Then I got missing -lelf on snmp again.
I installed elfutils-devel.

I think both rpm-devel and elfutils-devel should be required by snmp-devel, not
 by php rebuild.
 
Then php started to compile.

Comment 1 Marius Andreiana 2005-04-18 08:40:01 UTC
Found another one during linking, again in snmp:

grep: /usr/lib/libbeecrypt.la: No such file or directory
/bin/sed: can't read /usr/lib/libbeecrypt.la: No such file or directory
libtool: link: `/usr/lib/libbeecrypt.la' is not a valid libtool archive
make: *** [ext/snmp/snmp.la] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.62674 (%build)

Fixed by installing beecrypt-devel. Again, this should be in net-snmp-devel
Requires.


Comment 2 Joe Orton 2005-04-18 10:54:06 UTC
What versions of libtool, php, beecrypt are you using?

Comment 3 Joe Orton 2005-04-18 10:54:42 UTC
and net-snmp.

# rpm -q php libtool beecrypt-devel net-snmp-devel

Comment 4 Marius Andreiana 2005-04-18 11:07:55 UTC
Thanks for quick provided command line. I'm using fedora development.

package php is not installed
libtool-1.5.14.multilib2-6
beecrypt-devel-4.1.2-5
net-snmp-devel-5.2.1-9


Comment 5 Marius Andreiana 2005-04-18 11:10:14 UTC
The src rpm is php-5.0.4-2.src.rpm

Comment 6 Joe Orton 2005-04-18 11:11:52 UTC
This at least is a net-snmp bug - net-snmp-devel should Require rpm-devel etc.

checking for init_snmp in -lnetsnmp... no
configure: error: SNMP sanity check failed. Please check config.log for more
information.

config.log had:
/usr/bin/ld: cannot find -lrpm



Comment 7 Joe Orton 2005-04-19 07:57:11 UTC
*** Bug 149643 has been marked as a duplicate of this bug. ***

Comment 8 Radek Vokal 2005-04-19 11:39:51 UTC
Few more dependecies added to rawhide version of net-snmp-devel package. 

Comment 9 Marius Andreiana 2005-04-19 13:18:20 UTC
gcc-c++ still wasn't added to php:
http://cvs.fedora.redhat.com/viewcvs/devel/php/php.spec?rev=1.71&view=log

The rest are ok.


Comment 10 Joe Orton 2005-04-26 12:46:09 UTC
'tis done, thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.