Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155212 - Trackpoint Disabled in 2.6.11
Summary: Trackpoint Disabled in 2.6.11
Keywords:
Status: CLOSED DUPLICATE of bug 154728
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 05:42 UTC by Nicholas Andrade
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 16:38:53 UTC


Attachments (Terms of Use)

Description Nicholas Andrade 2005-04-18 05:42:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050408

Description of problem:
After installing kernel 2.6.11-1.14 on my laptop (Dell D610) via yum, I rebooted and found that the trackpoint (and its associated buttons) do not function in 2.6.11.  The touchpad and its buttons still work properly.  To clarify, when I state trackpoint, I'm referring to the eraserhead surrounded by the G, H, B keys and when I say touchpad, I'm referring to the pad below the space bar (see the following image: http://www.notebookreview.com/assets/4028.jpg)


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1.Install kernel 2.6.11 via
2.Reboot
3.Try to move mouse with the trackpoint
  

Actual Results:  The cursor will not respond to the trackpoint, and the buttons below it do no function.  xev does not return a response when pressing the mouse buttons.

Expected Results:  I expected the trackpoint to move the cursor and the left and right mouse buttons associated with the trackpoint to function.

Additional info:

I have since tried recompiling the kernel from source (which I extracted using the FC3 release notes from the SRPM) however the problem still persists (I used my .config that functions flawlessly in my recompiled 2.6.10 kernel).  I have experienced this problem in Gentoo (which I also run on this laptop) with gentoo-sources-2.6.11-rc5 & rc6.  I have read in forums that kernel 2.6.11.4 on Suse does not have this problem (the user was on a Dell M70 which also uses a trackpoint and a touchpad).

Comment 1 Dave Jones 2005-04-18 16:38:53 UTC

*** This bug has been marked as a duplicate of 154728 ***


Note You need to log in before you can comment on or make changes to this bug.