Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155208 - bad ascii pango text editing and cursor positioning for CJKI
Summary: bad ascii pango text editing and cursor positioning for CJKI
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Depends On: 138778
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-18 04:15 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 02:32:14 UTC


Attachments (Terms of Use)

Description Leon Ho 2005-04-18 04:15:46 UTC
+++ This bug was initially created as a clone of Bug #138778 +++

Description of problem: 
cursor is not in correct position when text editing with pango. Hence 
there are no way for user to edit text correctly. 
 
Seems it happens with any text with "spaces" 
 
How reproducible: 
everytime 
 
Steps to Reproduce: 
1. LANG=ja_JP.UTF-8 MOZ_ENABLE_PANGO=1 mozilla 
2. go to one of the bugzilla bug 
3. Type "I love monkey" enter 
and 
4. Type "cursoring and text editing has the same problem" 
5. Backspace five times 
Actual results: 
- cursor is in the middle of "y" 
- Backspace does not clear "oblem" character on screen but actually 
it is deleted. 
 
Expected results: 
cursor should be at the end and should clear "oblem" correctly 
 
Additional info:
Still happened in rawhide firefox 1.0.3-2. I need to cut and paste this entry
from gedit when editing this entry.

Comment 1 Leon Ho 2005-04-18 05:59:58 UTC
It is better compared to RHEL4. However it is very visible to use following test
case:

888888888888888888888888888888888888888 test

in any ja_JP.UTF-8 (worse) and zh_TW.UTF-8 (more worse) for example.

it seems related to bug #129541?

Comment 2 Christopher Blizzard 2005-04-25 18:03:51 UTC
This should be fixed in firefox 1.0.3-1.3.1.

Comment 3 Jens Petersen 2005-04-26 02:27:32 UTC
I writing this in firefox-1.0.3-1.3.1.x86_64 and as I highlight
the above 888888's with the mouse, I still see the fonts changing.

However I think this is the special case reported in bug 149991.


Comment 4 Jens Petersen 2005-04-26 02:32:14 UTC
Closing, since comment 1 is just bug 149991.


Note You need to log in before you can comment on or make changes to this bug.