Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155195 - Missing $file causes hang in "grep" on boot.
Summary: Missing $file causes hang in "grep" on boot.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 00:22 UTC by Terje Bless
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 10:08:47 UTC


Attachments (Terms of Use)
Fix missing "$file" in grep command. (deleted)
2005-04-18 00:22 UTC, Terje Bless
no flags Details | Diff

Description Terje Bless 2005-04-18 00:22:02 UTC
cf. message from Thomas Zehetbauer on fedora-devel (in URL field).

In initscripts-8.08-2, "/etc/init.d/network" will hang in "ifup-routes"
during boot.

The cause is a missing "$file" in the script, making "egrep" hang waiting
for data on STDIN. Patch attached.

Comment 1 Terje Bless 2005-04-18 00:22:02 UTC
Created attachment 113298 [details]
Fix missing "$file" in grep command.

Comment 2 Karsten Hopp 2005-04-18 10:08:47 UTC
fixed in initscripts-8.08-3 


Note You need to log in before you can comment on or make changes to this bug.