Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155194 - tst-cancel17 fails on kernel-2.6.11-1.14_FC3, works on 2.6.10-1.766_FC3
Summary: tst-cancel17 fails on kernel-2.6.11-1.14_FC3, works on 2.6.10-1.766_FC3
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 22:53 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 11:10:51 UTC


Attachments (Terms of Use)

Description John Reiser 2005-04-17 22:53:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The glibc internal testcases nptl/tst-cancel17 and tst-cancelx17
fail when run under kernel-2.6.11-1.14_FC3,
and succeed under   kernel-2.6.10-1.766_FC3.

The success output of tst-cancel17 is
-----
going to cancel tf in-time
going to cancel tf2 in-time
in-time cancellation succeeded
aio_cancel failed
going to cancel tf early
going to cancel tf2 early
early cancellation succeeded
-----
and the fail output is
-----
going to cancel tf in-time
going to cancel tf2 in-time
in-time cancellation succeeded
aio_cancel failed
going to cancel tf early
going to cancel tf2 early
tf2 cleanup handler not called
-----
Note that the last line is different.  The process exit() status is 0 versus 1.

This happens during "rpmbuild -ba --target i686 glibc.spec" after "rpm --install glibc-2.3.5-0.fc3-1.src.rpm".  I built glibc twice, once using
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3) on 2.6.10-1.766_FC3,
and once using
gcc (GCC) 3.4.3 20050227 (Red Hat 3.4.3-22.fc3) on 2.6.11-1.14_FC3.
nptl/tst-cancel17 fails using either libc.so on 2.6.11-1.14_FC3.
nptl/tst-cancel17 works using either libc.so on 2.6.10-1.766_FC3.
tst-cancelx17 exhibits similar behavior as tst-cancel17.



Version-Release number of selected component (if applicable):
glibc-2.3.5-0.fc3-1

How reproducible:
Always

Steps to Reproduce:
1.  rpm --install glibc-2.3.5-0.fc3-1.src.rpm 
2.  cd SPECS; rpmbuild -ba --target i686 glibc.spec >rpm.out 2>&1
3.  look at rpm.out transcript, and in BUILD/glibc-2.3.5/build-i686-linuxnptl/nptl/tst-cancel17.out

  

Actual Results:  nptl/tst-cancel17 and tst-cancelx17 fail under kernel-2.6.11-1.14_FC3.
They both succeed under                        kernel-2.6.10-1.766_FC3

Expected Results:  Tests should succeed on both kernels.

Additional info:

Comment 1 John Reiser 2005-04-18 18:18:47 UTC
nptl/tst-cancel17 also fails with glibc-2.3.5-1.src.rpm on ppc (Mac Mini) under
kernel-2.6.11-1.1240_FC4.

Comment 2 Jakub Jelinek 2005-04-26 11:10:51 UTC
The problem is that recent kernels no longer block when you write
more than fpathconf (fds[1], _PC_PIPE_BUF) bytes into a pipe from which
nobody is reading.  The tests will be eventually changed to do something
that will be guaranteed to block, at least for the time being.
Still, not sure why you are reporting it here.

Comment 3 John Reiser 2005-04-26 16:01:12 UTC
I report it here because:
0.  Distributed package does not pass its own regression test in then-current
environment.
1.  Fedora was the last to touch glibc-2.3.5-1.src.rpm .
2.  Problem has not been reported before in bugzilla.
3.  Reponsibility of kernel was/is uncertain (cause of problem was not
reasonably known when reported).
4.  GNU bug reporting process is exceedingly weak:  Must be reported against
GNU-only version (.src.rpm is laughed at), must be reported against CVS version
(no support for released version), reports are _usually_ ignored (no reponse for
months, if ever).



Note You need to log in before you can comment on or make changes to this bug.