Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155192 - Default torcs quick race fails because of missing files
Summary: Default torcs quick race fails because of missing files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: torcs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-04-17 22:01 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 16:55:30 UTC


Attachments (Terms of Use)

Description Marius Andreiana 2005-04-17 22:01:23 UTC
Installed torcs with
yum -y install torcs

(1/3): torcs-1.2.3-2.i386 100% |=========================| 1.6 MB    00:54
(2/3): torcs-data-tracks- 100% |=========================| 1.7 MB    01:00
(3/3): torcs-data-1.2.3-1 100% |=========================|  13 MB    07:33

Start the game, choose a quick race, get error shown in terminal on game exit:
WARNING: grscene:initBackground Failed to open shadow2.rgb for reading
WARNING:         no shadow mapping on cars for this track
WARNING: ssgLoadAC: Failed to open 'tracks/road/g-track-3/track.ac' for reading
/usr/bin/torcs: line 52:  9435 Segmentation fault      $LIBDIR/torcs-bin -l
$LOCAL_CONF -L $LIBDIR -D $DATADIR $*

Is this caused by a missing dependency on other torcs data packages?

Comment 1 Matthias Saou 2005-08-03 12:30:07 UTC
The problem here was that I thought TORCS would automatically check which tracks
were available at startup and use only those, so I put a virtual provides for
the main game on any of the 3 available tracks packages.

But apparently, the track it expects in this case is in the "road" tracks
package, so I'll change the minimum requirement to be strictly that one instead.

I'll test the change and release fixed packages today.


Note You need to log in before you can comment on or make changes to this bug.