Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155185 - new kernel upgrade 2.6.11-1.14fc3 cause my laptop touchpad to work funny.
Summary: new kernel upgrade 2.6.11-1.14fc3 cause my laptop touchpad to work funny.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: synaptics
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 20:20 UTC by juxhin sado
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-24 21:22:02 UTC


Attachments (Terms of Use)

Description juxhin sado 2005-04-17 20:20:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
it doesn't left click anymore like it used to. i wold click anywhere in the in the square. now the left click works only at certain areas. and it has not the same sensitivity. i do no know what is wrong. the pad works fine with the 2.6.10770 kernel.

Version-Release number of selected component (if applicable):
2.6.11-1.14fc3

How reproducible:
Always

Steps to Reproduce:
1.just boot the 2.6.11-1.14.FC3 kernel and it wont work
2.
3.
  

Actual Results:  the 

Expected Results:  the touchpad should have worked fine

Additional info:

Comment 1 Warren Togami 2005-04-17 21:26:39 UTC
It is impossible to diagnose your problem if you don't give hardware details.


Comment 2 Sitsofe Wheeler 2005-04-17 21:40:41 UTC
This sounds a lot like bug #155172. No way to know for sure until the reporter
adds some more information though.

Comment 3 Radek Bíba 2005-04-19 11:17:55 UTC
Yeah, the new kernel certainly contains a regression. My touchpad stopped
accepting clicks as well as the reporter's one. With the previous kernel it works
correctly again.

So I think this is a kernel error, not system-config-mouse, and I think this bug
is indeed a duplicate of bug #155172 and thus of bug #154728, my laptop has ALPS
touchpad too.

Comment 4 Paul Nasrat 2005-09-27 21:43:32 UTC
Please confirm if working using latest FC 3 errata kernel.

Comment 5 Radek Bíba 2005-09-29 07:08:33 UTC
Actually I use psmouse.proto=imps kernel parameter so I don't have a problem with
both touchpad and external mouse (well, it doesn't behave like ALPS then, no
scrolling is available, but I mostly use the external mouse anyway). However,
without this parameter (so using the ALPS driver) clicking using the square indeed
works for me with the latest kernel, although only in console, it needs hacking
xorg.conf to work in X using the ALPS driver.

Comment 6 Radek Bíba 2005-12-26 16:45:19 UTC
Good news, I've got an idea to update to newer synaptics package (from fc4 -
synaptics-0.14.0-2) because there were some ALPS-relevant improvements in its
changelog and _everything_ works great! Clicking and double-clicking in the
square, even scrolling in X (with appropriate changes to xorg.conf), external
mouse works with this configuration as well.

Comment 7 Dave Jones 2005-12-27 22:47:55 UTC
sounds like that needs backporting to FC3.


Comment 8 Paul Nasrat 2006-01-24 21:22:02 UTC
FC 3 has moved to Fedora Legacy.  FC 4 should resolve this issue.


Note You need to log in before you can comment on or make changes to this bug.