Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155182 - Icon does not appear in menus
Summary: Icon does not appear in menus
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: revelation
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Leemhuis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 18:31 UTC by Mason Kidd
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 06:58:37 UTC


Attachments (Terms of Use)

Description Mason Kidd 2005-04-17 18:31:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
After installing revelation, the icon does not appear in the menu.  Logging out/logging back in does not make the icon appear.

Version-Release number of selected component (if applicable):
revelation-0.4.3-2

How reproducible:
Always

Steps to Reproduce:
1. Install revelation
2. Go to Applications->Accessories
3.
  

Actual Results:  No icon for Revelation Password Manager

Expected Results:  The application icon for Revelation Password Manager should be next to it's menu item.

Additional info:

Comment 1 Thorsten Leemhuis 2005-04-25 17:52:09 UTC
I tried it here, can't reproduce it on fc4t2 (but I had installed revelation
some days ago already; but even after uninstall, log-out and reinstall the
problem did not show up)

/me wonders if we need this in %post :

# update icon themes
touch %{_datadir}/icons/hicolor
if [ -x /usr/bin/gtk-update-icon-cache ]; then
  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
fi

Will investigate further soon

Comment 2 Michael Schwendt 2005-04-26 12:52:22 UTC
First of all, I can reproduce this with any package, which installs a new
desktop icon. It takes some time before the new icon appears.

However, revelation doesn't install into /usr/share/pixmaps, but into the
hicolor icon-theme directory, in which GTK icon cache files are created and
used. It looks right to update the cache file via post/postun scriptlets.


Comment 3 Thorsten Leemhuis 2005-04-26 16:48:47 UTC
(In reply to comment #2)
> First of all, I can reproduce this with any package, which installs a new
> desktop icon. It takes some time before the new icon appears.

Maybe it stil was in my cache when I tried. I suspected something like that (I
tried to delete the cache but it seems I failed/missed it). 

> However, revelation doesn't install into /usr/share/pixmaps, but into the
> hicolor icon-theme directory, in which GTK icon cache files are created and
> used. It looks right to update the cache file via post/postun scriptlets.

I'll look into this deeper later this week. Probably other packages in fedora
will show the same problem?! Maybe I/we should try to fix them all directly.

Comment 4 Mason Kidd 2005-04-27 17:00:47 UTC
I tried this again on a fresh install of FC4T2, and got the same results (no
icon).  This also happens with the seahorse package (and it installs it's icons
in /usr/share/pixmaps).  Running 'touch /usr/share/icons/hicolor;
gtk-update-icon-cache /usr/share/icons/hicolor' did not cause the Revelation
icon to show up.

Comment 5 Thorsten Leemhuis 2005-04-27 17:11:41 UTC
(In reply to comment #4)
> Running 'touch /usr/share/icons/hicolor;
> gtk-update-icon-cache /usr/share/icons/hicolor' did not cause the Revelation
> icon to show up.

You did this as root, did you? Anyway, after you did this and log in and out the
icon *should* show up.

Comment 6 Thorsten Leemhuis 2005-05-11 06:58:37 UTC
Update package publisched that updates gtk-update-icon-cache on (un)install.
Icon should appear after a re-login at the latest. AFAIK that all we can do ATM.
Correct me if I wrong (and reopen if neccessary).


Note You need to log in before you can comment on or make changes to this bug.