Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155177 - Bibliography not formatting correctly
Summary: Bibliography not formatting correctly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 16:12 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 09:12:04 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2005-04-17 16:12:21 UTC
Description of problem:
When inserting a bibliography, the number or reference from the main document is
not being inserted prior to the actual details

Version-Release number of selected component (if applicable):
1.9.92

How reproducible:
Always

Steps to Reproduce:
1. Create a number of bibliographic references
2. Insert a bibliography
3.
  
Actual results:
The reference for the publication should be the first item on the bibliography.
For example in the text there maybe the lines

Schildt[1] maintains that the correct return type for main() is void

[1] is defined as anything

In the bibliography, this should be outputted as

[1] Schildt, H. C for Beginners.. (whatever)

I can't see anyway of generating the [1]!

Expected results:
The bibliography should be have the reference prior to any details.

Additional info:
This has not changed since OOo pre 1.0. I moaned about it then as well (to the
OOo developers and at a conference!!!!)

For an example, please use the file attached to bug #155176 as this also has the
bibliographic references for that document defined.

Comment 1 Caolan McNamara 2005-04-18 09:12:04 UTC
You'll have to open a bug against qa.openoffice.org for such a feature change
with OOo. It's too wide an issue to address specifically in a distribution
specific version.

Comment 2 dave 2005-06-06 02:59:10 UTC
1. right click on bib and select edit table
2. select styles tab
3. from right hand list [paragraph styles] select bibliography 1, then click edit
4. select numbering tab and choose numbering style = 1.


Note You need to log in before you can comment on or make changes to this bug.