Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155170 - /etc/ant.com ignores users ANT_HOME variable
Summary: /etc/ant.com ignores users ANT_HOME variable
Keywords:
Status: CLOSED DUPLICATE of bug 155165
Alias: None
Product: Fedora
Classification: Fedora
Component: ant
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 14:43 UTC by Brian G. Anderson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 11:04:34 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2005-04-17 14:43:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 StumbleUpon/1.9993 Firefox/1.0.3

Description of problem:
I run an alternate copy of ant for some products that I build.  Because the distro's /etc/ant.conf *always* sets the ANT_HOME it interferes with the alternate installation

Version-Release number of selected component (if applicable):
ant-1.6.2-3jpp_4fc

How reproducible:
Always

Steps to Reproduce:
1. install an alternate copy of ant somewhere and set ANT_HOME to the new path
2. change into the ant copy directory and run ant from its bin directory
3.
  

Actual Results:  The distro copy of ant is used.  This is very noticable because my ant copy will have a special ant task jar in the ant copy's lib directory.  My ant builds will fail because the /etc/ant.conf forces the ant to use the distro directories.

Expected Results:  /etc/ant.conf should leave ANT_HOME untouched if it is already set so that other invocations of ant will use their correct home directory

Additional info:

Comment 1 Gary Benson 2005-04-18 11:04:34 UTC

*** This bug has been marked as a duplicate of 155165 ***


Note You need to log in before you can comment on or make changes to this bug.