Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155167 - gcc ICE when compiling DOSBox
Summary: gcc ICE when compiling DOSBox
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 14:08 UTC by Luca Barbieri
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-02 09:13:18 UTC


Attachments (Terms of Use)
temp file produced by g++ (deleted)
2005-04-17 14:08 UTC, Luca Barbieri
no flags Details

Description Luca Barbieri 2005-04-17 14:08:06 UTC
Description of problem:
gcc ICEs on src/dos/drive_fat.cpp from SRPM .

A reduced 20 line version is attached.


Version-Release number of selected component (if applicable):
gcc-4.0.0-0.42

How reproducible:
Always.

Steps to Reproduce:
1. Compile the attached source with g++ -c -O2 file.cpp
  
Actual results:
foo.cpp: In function âvoid ice()â:
foo.cpp:10: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccAieyM9.out file, please attach this to
your bugreport.


Expected results:
It works.

Additional info:
gdb doesn't seem to provide a symbolic backtrace even though gcc-debuginfo is
installed

Comment 1 Luca Barbieri 2005-04-17 14:08:06 UTC
Created attachment 113288 [details]
temp file produced by g++

Comment 2 Jakub Jelinek 2005-05-02 09:13:18 UTC
Can't reproduce with gcc-c++-4.0.0-2.


Note You need to log in before you can comment on or make changes to this bug.