Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155161 - grub keeps rebooting the pc on a clean install of fedora 3
Summary: grub keeps rebooting the pc on a clean install of fedora 3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 10:39 UTC by Ruwan
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 02:01:05 UTC


Attachments (Terms of Use)

Description Ruwan 2005-04-17 10:39:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
HI

Im fairly new to linux. I recently purchased a new pc and tried to install the full package of fedora 3 on it. Its the first time I tried to install fedora on a pc running a SATA harddisk. Well the installation seems to go well. Everything installs and then im prompted to reboot the pc. Once having been rebooted the pc gets up to the bit where it tries to launch grub and then it reboots again and this just keeps happening. I installed grub on MBR of the harddisk. If there is any aditional info holler back.

 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Ruwan 2005-04-17 11:09:32 UTC
just a notice. BIOS detects my sata device. But when I set my boot device i 
just select hdd. Does it know im indicating my SATA device or is it expecting 
an IDE device. I tried installing XP before and it wouldnt see my SATA at all.

Comment 2 Sitsofe Wheeler 2005-04-17 21:43:44 UTC
Ruwan,

You are probably going to have to give some extra details about which hardware
you have...

Comment 3 Ruwan 2005-04-17 23:31:28 UTC
here is my hardware specs Gigabyte 8S661FXM-775 SIS, 3Mhz P4, 512M hyundai DDR, 
seagate 80g sata HD. The only other IDE device connected is my dvd rw drive.

I was searching the net and I found similar problems where the computer would 
reboot at grub stage 2. But some of these were resolved by re installing 
grub/modifying grub. I spent last night attempting to reinstall grub/ modify 
the grub.conf file. I thought it was a problem with mapping the partitions into 
grub. The only difference was grub now crashed at stage 1.5.

So i clean installed everything making a boot partition and running grub from 
there but that doesnt work either.

Im at work now but Ill post my grub.conf file up later if that would be of any 
assistance.

Comment 4 Ruwan 2005-04-17 23:47:31 UTC
this bug seems similar 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123611
but at the moment it doesnt help me.

Comment 5 Ruwan 2005-04-19 02:01:05 UTC
I managed to fix the boot partition problem by reinstalling grub from linux 
rescue. But I wanted to boot from the MBR so I reinstalled everything again and 
planned on doing the grub reinstall via linux rescue, but it turns out I didnt 
have to as this time it works perfect. Seems pretty strange!!??

well its fixed for me.


Note You need to log in before you can comment on or make changes to this bug.