Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155158 - [OOo][gcj] Can't yum update 1.9.92-2 because of libgcj-4.0.0.jar conflict in /usr/share/java
Summary: [OOo][gcj] Can't yum update 1.9.92-2 because of libgcj-4.0.0.jar conflict in ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 09:39 UTC by Dr. Peter Boy
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 4.0.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-24 12:13:45 UTC


Attachments (Terms of Use)

Description Dr. Peter Boy 2005-04-17 09:39:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de_DE; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
If you try to upgrade on the x86_64 platform using yum you get the message:

Transaction check error: file /usr/share/java/libgcj-4.0.0.jar from install
of libgcj-4.0.0-0.42 conflicts with file from package libgcj-4.0.0-0.42

libgcj is installed as x86_64 binary, the file libgcj.so.6 and libjawt.so.6 are located in /usr/lib86.

If you try to update using rpm directly, you get the error:

Failed dependencies:
   libgcj.so.6 is needed ...
   libjawt.so.6 is needed ...

of course, because they are in /usr/lib64 instead of /usr/lib where OO searches

Version-Release number of selected component (if applicable):
openoffice.org 1.9.92-2

How reproducible:
Always

Steps to Reproduce:
1.  Install Test2 on x86_64
2.  Try to update openoffice using yum
3.
  

Actual Results:  Update failes

Expected Results:  updage should proceed

Additional info:

Comment 1 Caolan McNamara 2005-04-18 09:55:17 UTC
caolanm->jakub: The conflict here looks between i386 libgcj-4.0.0.jar and x86_64
libgcj-4.0.0.jar. OOo is 32bit of course and needs 32bit libgcj.

Comment 2 Jakub Jelinek 2005-04-24 12:13:45 UTC
4.0.0-1's libgcj-4.0.0.jar is identical on all arches.


Note You need to log in before you can comment on or make changes to this bug.