Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155154 - Oops and kernel panic on USB flash disc unplug
Summary: Oops and kernel panic on USB flash disc unplug
Keywords:
Status: CLOSED DUPLICATE of bug 153971
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 07:08 UTC by fmachal
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 10:12:52 UTC


Attachments (Terms of Use)
messages file (deleted)
2005-04-17 07:11 UTC, fmachal
no flags Details
messages-2.6.9-11 (deleted)
2005-05-23 08:10 UTC, fmachal
no flags Details
messages-2.6.9-6.46.EL (deleted)
2005-05-23 08:11 UTC, fmachal
no flags Details

Description fmachal 2005-04-17 07:08:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.6) Gecko/20050324 Firefox/1.0.2 Red Hat/1.0.2-1.4.1.centos4

Description of problem:
The kernel panicked on unplug of the USB flash disc with the message in the attachment.

Problem is fixed with
http://marc.theaimsgroup.com/?l=bk-commits-head&m=110090243520749&w=2

Version-Release number of selected component (if applicable):
2.6.9-5.0.3.EL 2.6.9-6.36.EL 2.6.9-6.36.ELsmp

How reproducible:
Always

Steps to Reproduce:
Plug and unplug the USB flash disc.

  

Additional info:

Comment 1 fmachal 2005-04-17 07:11:53 UTC
Created attachment 113281 [details]
messages file

Comment 5 Pete Zaitcev 2005-05-19 07:52:12 UTC
Reqestor, please provide the complete dmesg or /var/log/messages
which includes the moment of connect, not only disconnect.

I suspect this may be a dup of bug 153971. Fill dmesg should clear it.


Comment 6 fmachal 2005-05-23 08:08:25 UTC
Hi, kernel from  ftp://people.redhat.com/zaitcev/153971/ solved the problem.

Comment 7 fmachal 2005-05-23 08:10:24 UTC
Created attachment 114700 [details]
messages-2.6.9-11

Comment 8 fmachal 2005-05-23 08:11:09 UTC
Created attachment 114701 [details]
messages-2.6.9-6.46.EL

Comment 9 Pete Zaitcev 2005-05-23 10:12:52 UTC
Thanks for the messages. Indeed, there was a double kobject registration.
I think this can be marked duplicate.


*** This bug has been marked as a duplicate of 153971 ***


Note You need to log in before you can comment on or make changes to this bug.