Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155153 - rendering problems when running mutt under screen
Summary: rendering problems when running mutt under screen
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 06:32 UTC by Jim Meehan
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 09:39:42 UTC


Attachments (Terms of Use)

Description Jim Meehan 2005-04-17 06:32:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
Having some garbled text problems when running mutt under screen.  This is on
a remote FC3 server that lives in a colo facility.  When I use right-arrow
or left-arrow to scroll through a list of messages, the mutt status line gets
overwritten, some text lines don't get updated, etc.  The problem is especially
bad when viewing my spam/junkmail folder where there are lots of messages with
subject lines in unicode/utf-8, etc.

Hitting ^L to redraw the screen does clear up the problem (mostly).
There are still a few out-of-place characters even after ^L when viewing
my spam folder.

I've tried ssh'ing in from Terminal.app in Mac OS X, and PuTTY in Windows -- problem is the same with both.

If I run mutt by itself, without starting screen first, it seems to be 
mostly okay.  Still a few rendering problems in my spam folder.

I see there's a bugzilla bug #139294 open for a similar problem, with mutt
running under gnome-terminal.  Maybe related?

Version-Release number of selected component (if applicable):
screen-4.0.2-5

How reproducible:
Always

Steps to Reproduce:
1. ssh into FC3 machine
2. start screen 
3. start mutt 
4. go to a folder with several pages of messages
5. scroll through message listing using right/left arrow keys

Actual Results:  mutt status line overwritten, text snippets from other pages of messages not cleared from screen, etc.

Expected Results:  message list should be displayed correctly, status line should remain intact

Additional info:

screen shot of garbled mutt display:

http://vpizza.org/~jmeehan/mutt-problem.pdf

Comment 1 John Thacker 2005-04-17 15:34:05 UTC
This is a known problem with vte as shipped in FC3, and is the same as bug
#139294.  It's been fixed in Rawhide (and the FC4 Test releases) for a while.

Even with the fixed vte, there are problems if you ssh from FC2 to FC3.  But the
problems with screen, PuTTY, etc., are fixed.

Personally, pushing a fixed vte update out there might be a good idea.  But
that's the package with the problem, not screen.

Comment 2 Petr Rockai 2005-04-27 09:39:42 UTC
Please reopen with the right component if still relevant at all. The above  
scenario works for me without problems, so definitely not screen's fault. I  
suppose John is right here and the problem is (was) with vte... 


Note You need to log in before you can comment on or make changes to this bug.