Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155152 - Internal compiler error
Summary: Internal compiler error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 156498
TreeView+ depends on / blocked
 
Reported: 2005-04-17 06:19 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0.0-0.43
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 12:42:33 UTC


Attachments (Terms of Use)
Preprocessed source (deleted)
2005-04-17 06:21 UTC, Michael A. Peters
no flags Details

Description Michael A. Peters 2005-04-17 06:19:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
While compiling a cvs checkout of gnomesword -

sword_main.cc: In member function int BackEnd::module_get_testaments(const char *):
sword_main.cc:745: internal compiler error: in cgraph_mark_reachable_node, at cg raph.c:477
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccmR6j01.out file, please attach this to yo ur bugreport.

I apologize for not being able to determine if this is a duplicate of a known issue or not.

Version-Release number of selected component (if applicable):
gcc-4.0.0-0.42

How reproducible:
Didn't try

Steps to Reproduce:
1. cvs chechout gnomesword1
2. ./autogen.sh
3. make
  

Actual Results:  internal compiler error

Expected Results:  I wasn't sure what to expect - it was my first time trying to compile gnomesword

Additional info:

If you need to try to reproduce it - the gnomesword2 cvs instructions are here:
http://gnomesword.sourceforge.net/download.php

gnomesword2 requires a CVS version of sword to compile.
That can be obtained here:

http://crosswire.org/sword/ALPHAcckswwlkrfre22034820285912/alpha/sword-1.5.7.100.tar.gz

It builds with standard ./configure ; make

The ccmR6j01.out file will be attached.

Comment 1 Michael A. Peters 2005-04-17 06:21:55 UTC
Created attachment 113280 [details]
Preprocessed source

Comment 2 Jakub Jelinek 2005-04-28 12:42:33 UTC
Should be fixed in gcc-4.0.0-0.43 and later.


Note You need to log in before you can comment on or make changes to this bug.