Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155146 - failure to open anaconda generated file
Summary: failure to open anaconda generated file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kickstart
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-17 03:04 UTC by Eugene Kanter
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: 5.0.0
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-05 17:42:41 UTC


Attachments (Terms of Use)
anaconda generated ks.cfg file. (deleted)
2005-04-17 03:04 UTC, Eugene Kanter
no flags Details

Description Eugene Kanter 2005-04-17 03:04:14 UTC
Description of problem:

unable to open anaconda generated anaconda-ks.cfg

Version-Release number of selected component (if applicable):

system-config-kickstart-2.5.16-2

How reproducible:

always

Steps to Reproduce:
1. open attached file with system-config-kickstart-2.5.16-2

  
Actual results:

traceback

Expected results:

file opens.

Additional information:

there seems to be two areas wich cause problem. they need to be taken care one
at a time. to see "--onboot no" problems comment out disk lines.

1. "--onboot no" in line 9
2. raid configuration.

Comment 1 Eugene Kanter 2005-04-17 03:04:14 UTC
Created attachment 113276 [details]
anaconda generated ks.cfg file.

Comment 2 Chris Lumens 2005-09-08 20:56:27 UTC
The same explanation on bug 163162 applies here as well, but I'm not marking
this as a duplicate of that since they're on different RHEL versions.  Adding to
proposed list.

Comment 8 Chris Lumens 2006-01-16 20:50:50 UTC
There are several of these sorts of bugs in system-config-kickstart as shipped
in RHEL3, RHEL4, and their Fedora Core counterparts.  The correct fix is
essentially a reimplementation of how kickstart files are handled which is a
very invasive change with lots of potential for creating more bugs.  This work
has been done in the form of the pykickstart package for FC5.  The next major
RHEL release will pick up these changes and take care of the problem.

Comment 9 Chris Lumens 2006-06-05 17:42:41 UTC
This will be fixed in the next major release of RHEL.


Note You need to log in before you can comment on or make changes to this bug.