Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155142 - Undefined symbol
Summary: Undefined symbol
Keywords:
Status: CLOSED DUPLICATE of bug 154958
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 23:27 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-17 07:57:08 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2005-04-16 23:27:27 UTC
Description of problem:
Audacity is currently not starting due to an undefined symbol being found.
Attempting to build from source results in multiple errors

Version-Release number of selected component (if applicable):
2.4.2-9

How reproducible:
Always

Steps to Reproduce:
1. Start audacity as installed from fedora-extras
2. Download the source from sourceforge and attempt to build
3.
  
Actual results:
Running the version from fed-extras gives
audacity: symbol lookup error: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol:
_ZTV11wxFileProto

Trying to compile from source gives
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxListStringNode::~wxwxListStringNode()'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxMenuItemListNode::~wxwxMenuItemListNode()'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `vtable for wxFileProto'

Expected results:
The procompiled version should work or the source version should compile

Additional info:

Comment 1 Dams 2005-04-17 07:57:08 UTC

*** This bug has been marked as a duplicate of 154958 ***


Note You need to log in before you can comment on or make changes to this bug.