Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155127 - 2.6.11-1.14_FC3 poweroff always fails
Summary: 2.6.11-1.14_FC3 poweroff always fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 18:11 UTC by Martin
Modified: 2015-01-04 22:18 UTC (History)
32 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-12 23:45:40 UTC


Attachments (Terms of Use)
acpidmp output (deleted)
2005-07-16 12:51 UTC, Martin
no flags Details
dmidecode output (deleted)
2005-07-16 12:54 UTC, Martin
no flags Details

Description Martin 2005-04-16 18:11:47 UTC
+++ This bug was initially created as a clone of Bug #132761 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.2)
Gecko/20040803

Description of problem:
system report ACPI_POWER_OFF CALLED but don't go off.

Version-Release number of selected component (if applicable):
FC3 Kernel 2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1.call poweroff of shutdown -h now
    

Actual Results:  ACPI_POWER_OFF CALLED is the last message - to power
of the machine - I pressed for 5 sec the power off buttom.

Additional info:

Comment 1 Alexander Kain 2005-04-16 18:53:05 UTC
On a Dell N-series 370, issuing poweroff from within X hangs the system (can't
switch to a virtual console, but didn't try logging on over the network). If I
initiate a shutdown via acpid (by momentarily hitting the power switch), it goes
down fine.

Comment 2 Martin 2005-04-19 07:40:18 UTC
Just changed my kernel line in grub.conf to

        kernel /boot/vmlinuz-2.6.11-1.14_FC3 ro root=LABEL=/1 rhgb quiet
acpi=ht

rebooted, shut down, and achieved power off!  Now, can anyone explain
why this works?

Comment 3 Barry K. Nathan 2005-04-19 10:54:43 UTC
AFAIK, "acpi=ht" disables much of the kernel's ACPI support. Maybe that's why
it's working for you.

It would be good to try a kernel with *both* of the following patches applied,
and see if that fixes the problem:

http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.11/2.6.11-mm4/broken-out/acpi-poweroff-fix.patch
http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.11/2.6.11-mm4/broken-out/acpi-poweroff-fix-fix.patch

(They're in the Linux ACPI BitKeeper tree, so they'll probably be incorporated
into the mainline kernel by 2.6.13. I have no idea if they'll be incorporated by
2.6.12 however.)

Comment 4 stef 2005-06-16 19:03:11 UTC
Didn't work for me, the acpi=off or acpi=ht parameters just does my kernel boot
freezing very early.
Screenshot here https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=115424

I'm a bit reluctant to patch and compile an kernel tough, I hope those patches
(if fixes) will be incorporated soon.

Comment 5 Alexander Kain 2005-06-16 21:36:46 UTC
2.6.11-1.27_FC3 fixes this for me.

Comment 6 Dave Jones 2005-07-15 17:41:13 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Martin 2005-07-16 12:40:24 UTC
in the meantime i switched to fc4, kernel-2.6.12-1.1398_FC4
problem still exists with this new kernel.

Comment 8 Martin 2005-07-16 12:51:58 UTC
Created attachment 116839 [details]
acpidmp output

acpidmp output

Comment 9 Martin 2005-07-16 12:54:22 UTC
Created attachment 116840 [details]
dmidecode output

Comment 10 Martin 2005-08-03 17:08:35 UTC
kernel-2.6.12-1.1446_FC5 seems to print more messages, but power off fails again:

Halting system ...
md: md0 switched to read-only mode.
ACPI: PCI interrupt for device 0000:02:01.0 disabled
ACPI: PCI interrupt for device 0000:00:1f.5 disabled

Comment 11 stef 2005-09-05 19:25:10 UTC
for power-off problem, you should have a look at bug 160775

Comment 12 Martin 2005-09-09 16:23:39 UTC
the problem still exists with 2.6.13 vanilla kernel, the kernel do not poweroff
my  machine with the MSI Board.

Comment 13 Dave Jones 2005-09-30 06:10:19 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 14 Christopher Chua 2005-09-30 16:05:29 UTC
Using 2.6.13-1.1526_FC4. Bug still exist. On a Toshiba M50 laptop with Phoenix BIOS.

Comment 15 Martin 2005-09-30 21:22:53 UTC
problem still exists with 2.6.13-1.1526_FC4

Comment 16 Christopher Chua 2005-09-30 23:57:27 UTC
Why does entering "shutdown -h now" from the command line works but the
Gnome/KDE shutdown option will cause this problem?

Comment 17 stef 2005-10-01 15:58:39 UTC
for Comment #16 : 
I guess Gnome/KDE shutdown gives the same as the command line "poweroff" (with
possibly options) and doesn't use  "shutdown", now the question is what are the
behavious differences between those commands ?

Comment 18 Dave Jones 2005-11-10 19:08:12 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.


Comment 19 Martin 2005-11-10 20:11:54 UTC
problem still exists with kernel-2.6.14-1.1636_FC4.i686.rpm 

Comment 20 Martin 2006-01-10 07:38:26 UTC
a good day for peoples with the mSI MS-6758 (875P Neo) Board.
With kernel-2.6.15-1.1823_FC4.i686.rpm the problem doesn't longer exists.
'shutdown -h now' works for me.


Comment 21 Germano Massullo 2012-07-15 23:11:37 UTC
could you please give a look to
https://bugzilla.redhat.com/show_bug.cgi?id=840331


Note You need to log in before you can comment on or make changes to this bug.