Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155125 - Gnome-applets requires apmd, conflicts with apmud on PowerPC
Summary: Gnome-applets requires apmd, conflicts with apmud on PowerPC
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 18:02 UTC by W. Michael Petullo
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-22 15:14:23 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2005-04-16 18:02:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
The gnome-applets package cannot be installed on an Apple system that uses apmud instead of apmd.

The gnome-applets package requires libapm.so.1.  Libapm.so.1 is provided by apmd.  Apmd conflicts with apmud.  The apmud package is in Fedora Extras and is the preferred power management system for modern Apple systems.

Version-Release number of selected component (if applicable):
gnome-applets-2.10.1-1

How reproducible:
Always

Steps to Reproduce:
On a system that uses apmud instead of apmd, try to perform a yum update.
  

Actual Results:  The update fails because of the dependency problem.

Additional info:

Comment 1 Ray Strode [halfline] 2005-04-18 18:05:05 UTC
Does the battstat applet work with apmud? Is apmud just a drop in replacement
for apmd?

Comment 2 W. Michael Petullo 2005-04-18 18:31:48 UTC
No, apmud is not a drop in replacement for apmd.  /usr/libexec/battstat-applet-2
requires libapm.so.1 and this is not provided by apmud.

Comment 3 Ray Strode [halfline] 2005-04-18 18:44:17 UTC
So the solution would have to be two part:

1) build gnome-applets without battstat applet on powerpc until 2) can happen
2) eventually port battstat applet to use apmud

If apmd already works on ppc I would say doing 1) would be a really bad idea
(because people without apmud would suddenly lose a useful feature for no reason).

What's the state of apmd on powerpc?  David, do you know?

Comment 4 David Woodhouse 2005-04-18 20:53:45 UTC
The battstat_applet just uses a routine in libapm.so.1 which parses /proc/apm.

We don't use apmd on PPC, and neither does battstat_applet. The best answer is
probably to split the apm package into two parts -- apmd itself, and the library.

Alternatively, just import that fairly simple routine into battstat_applet
itself, and drop the dependency altogether.

Please don't stop building battstat_applet on ppc.

Comment 5 Ray Strode [halfline] 2005-04-20 14:32:23 UTC
Hi,

I've built a fix that should show up in tomorrow's rawhide.  Can one of you guys
test it for me and close the bug if it works?

Comment 6 W. Michael Petullo 2005-04-22 15:14:23 UTC
The dependency is now gone any the GNOME battery applet now works on my iBook. 
Thank you, Ray and David!


Note You need to log in before you can comment on or make changes to this bug.