Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155123 - kernel source compile fails with undefined reference to irq_ctx_init
Summary: kernel source compile fails with undefined reference to irq_ctx_init
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 17:27 UTC by Joe Acosta
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-16 19:52:58 UTC


Attachments (Terms of Use)

Description Joe Acosta 2005-04-16 17:27:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.3.2

Description of problem:
I ran rpmbuild --rebuild --target i586 kernel-2.6.11-1.14_FC3.src.rpm

In my home directory under rpmbuild/BUILD the source was extracted and patches applied.

Since I have an athlon I wanted a kernel compiled for athlon, not i586 / i686.  So after it ran through I have the kernel files in rpmbuild/SOURCE and a spec file. I stopped the build and cleaned out the BUILD directory.

Then use rpmbuild -bp to patch the source and get it extracted.  



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. extract the source rpm 
2. use rpmbuild -bp --target i586 kernel-2.6.11-1.14_FC3.src.rpm
3. cd rpmbuild/BUILD/kernel-2.6.11/linux-2.6.11
4. make gconfig 
5. select athlon
6. go to the kernel debugging options and DESELECT ALL of them
7. compile
  

Actual Results:  output showed 

arch/i386/kernel/i8259.c: In function `init_IRQ':
arch/i386/kernel/i8259.c:429: warning: implicit declaration of function `irq_ctx_init'

then build failed with:

arch/i386/kernel/built-in.o(.init.text+0x1b43): In function `init_IRQ':
: undefined reference to `irq_ctx_init'
arch/i386/kernel/built-in.o(.init.text+0x1b68): In function `init_IRQ':
: undefined reference to `irq_ctx_init'
make: *** [.tmp_vmlinux1] Error 1arch/i386/kernel/i8259.c: In function `init_IRQ':
arch/i386/kernel/i8259.c:429: warning: implicit declaration of function `irq_ctx_init'


arch/i386/kernel/built-in.o(.init.text+0x1b43): In function `init_IRQ':
: undefined reference to `irq_ctx_init'
arch/i386/kernel/built-in.o(.init.text+0x1b68): In function `init_IRQ':
: undefined reference to `irq_ctx_init'
make: *** [.tmp_vmlinux1] Error 1

Expected Results:  I'm thinking it should have compiled?

Alternately it should have told me what the problem was?  

Or it should have defined one of the two symbols.  



Additional info:

in include/asm/irq.h
irq_ctx_init is only defined if one of the below is defined:

CONFIG_4KSTACKS
CONFIG_XEN

not sure which needs to be defined, I could not find CONFIG_XEN in the .config file.  
CONFIG_4KSTACKS is a kernel debug option, so I don't know why I have to have that set.

Comment 1 Dave Jones 2005-04-16 19:52:58 UTC

*** This bug has been marked as a duplicate of 126342 ***


Note You need to log in before you can comment on or make changes to this bug.