Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155102 - Setting up IDE HD on S3 resume
Summary: Setting up IDE HD on S3 resume
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 09:52 UTC by Albert Vilella
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 12:27:58 UTC


Attachments (Terms of Use)

Description Albert Vilella 2005-04-16 09:52:46 UTC
Description of problem:
The laptop won't set up IDE from a S3 suspend.
Keyboard and mouse input ok, all fine but the hda seems to have trouble
recovering (hda led blinking hard), can't execute any command because the hda is
not accessible. Kernel outputs DMA timeouts for the hdd...  After half a minute,
decides it can't set up, and goes for a controlled shutdown.

Version-Release number of selected component (if applicable):
Since ACPI exists

How reproducible:
Always

Steps to Reproduce:
1.Suspend to S3. 
2.The power LED blinks. 
If I press the power or specials button, it restores graphics, keyboard
and mouse are working but hda has problems.
3.Goes to controlled shutdown after a minute
  
Actual results:
Goes to controlled shutdown after a minute

Expected results:
Resume on S3 suspend

Additional info:
The same happens with Ubuntu Hoary:
https://bugzilla.ubuntu.com/show_bug.cgi?id=8159
This is Matthew Garrett's comment:
"Linux currently has no real support for setting up IDE interfaces on resume.
Some machines are kind enough to set the IDE interface up themselves, but on
others we're doomed to failure. I'm looking into implementing this, but it won't
happen until some time after Hoary."

Comment 1 Alan Cox 2005-04-18 12:27:58 UTC
Set to upstream


Note You need to log in before you can comment on or make changes to this bug.