Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155100 - Zombie sshd process remains after the end of ssh session
Summary: Zombie sshd process remains after the end of ssh session
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 08:52 UTC by Vovchik Vovkovich
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 12:39:32 UTC


Attachments (Terms of Use)

Description Vovchik Vovkovich 2005-04-16 08:52:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When working with server via ssh, after logout got zombie shell and sshd processes. These zombie processes stay for a long time and they can be killed by "kill -9" command. 

Version-Release number of selected component (if applicable):
openssh-3.9p1-8.0.1

How reproducible:
Sometimes

Steps to Reproduce:
1. Log in to server over ssh
2. Log off

  

Actual Results:  Sometimes zombie processes of shell and sshd appear.

Expected Results:  There should be no session processes after logout.

Additional info:

After logout of user "qwert" following processes remain

[root@host /]# ps aux | grep qwert

root      8305  0.0  0.1  6900 1868 ?        Ss   08:38   0:00 sshd: qwert[priv]
qwert     8318  0.0  0.1  7104 2016 ?        S    08:39   0:00 sshd: qwert@pts/8
qwert     8319  0.0  0.0     0    0 ?        Zs   08:39   0:00 [bash] <defunct>
root     24662  0.0  0.0  5144  696 pts/9    S+   15:48   0:00 grep qwert

Comment 1 Tomas Mraz 2005-04-18 07:36:51 UTC
I cannot reproduce this bug here.

Does it happen even if you connect to the machine and logout immediately?

Which ssh client do you use? And could you try to reproduce the problem using
various ssh clients?

Also you could try to rebuild the openssh-4.0p1-2 from Fedora Core Development
and install it on your machine and try if it solves the problem or not.


Comment 2 Tomas Mraz 2005-06-29 12:39:32 UTC
I cannot reproduce it and reporter doesn't respond.



Note You need to log in before you can comment on or make changes to this bug.