Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155098 - KDE uses desktop tools from GNOME
Summary: KDE uses desktop tools from GNOME
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-16 07:49 UTC by Paul Osmialowski
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-16 08:11:41 UTC


Attachments (Terms of Use)

Description Paul Osmialowski 2005-04-16 07:49:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
I was surprised that KDE desktop icons bindings are managed by GNOME control-center tool called gnome-default-applications-properties. I wanted the e-mail icon in KDE to run Thunderbird instead of Evolution. It had taken some time before I realised that I should use gnome-default-application-properties! In my opinion this tool should be called desktop-default-application-properties


Version-Release number of selected component (if applicable):
control-center-2.8.0-12, htmlview-3.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. Install KDE
2. Try to run Thunderbird using KDE desktop icon (it is bound to launchmail script from htmlview package)

Actual Results:  You can discover that KDE desktop icons are managed by GNOME util. That's confusing!


Expected Results:  More generic names of desktop tools


Additional info:

Comment 1 Warren Togami 2005-04-16 08:11:41 UTC
Sorry, we cannot rename upstream projects for non-technical reasons.  The reason
why our KDE relies on GNOME's preferred applications chooser in order to choose
preferred applications is because the KDE project chose not to participate in
cross-desktop standards making a generic thing like this possible.  Instead KDE
is designed very KDE-centric.  They can't possibly imagine why you would not
want to use Konqueror or Kmail.  There is no KDE way of choosing preferred
applications from a menu.


Note You need to log in before you can comment on or make changes to this bug.