Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155093 - No sound input with emu10k1 driver
Summary: No sound input with emu10k1 driver
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-04-16 04:11 UTC by Nathan G. Grennan
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-01-17 16:43:06 UTC

Attachments (Terms of Use)

Description Nathan G. Grennan 2005-04-16 04:11:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050322 Galeon/1.3.20

Description of problem:
I have tried to get input working under 2.6.11-1.1240, both line in and microphone. I have also tried 2.6.11-1.1234 and have the same problem. I tried adjusting pretty much all mixer settings. Output worked just fine. So I could play music. 2.6.11-1.1226 works just fine.

The mixer listings look very different in 2.6.11-1.1240 vs. 2.6.11-1.1226.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install 2.6.11-1.1240

Actual Results:  No sound input

Expected Results:  Sound input works

Additional info:

Comment 1 Thomas J. Baker 2005-08-30 13:55:21 UTC
I'm running 2.6.12-1.1447_FC4smp on an FC4 system and I have the same problem.
gnome-volume-control doesn't even show a capture section. System is a Dell
Precision 650 with dual 64 bit Xeons.

Comment 2 Dave Jones 2005-08-30 19:03:04 UTC
Thomas, I think you have a different problem.
The volume control applet doesn't show any inputs unless you enable them.
Go to Edit->Preferences, and enable for eg, Microphone, and a Capture tab appears.

Nathan seems to have the controls, but they don't do anything.

Comment 3 Thomas J. Baker 2005-08-30 19:22:13 UTC
I tried enabling them but no capture tab appeared. With them enabled, I get two
sliders for Mic or Aux in the playback tab. I tried running alsamixer and the
capture sliders for various inputs have no effect. It's like
gnome-volume-control can't see any input elements. Alsamixer shows them but they
don't seem to do anything.

Comment 4 Thomas J. Baker 2005-08-31 13:16:17 UTC
I actually have the exact same symptoms on my home Athlon64 system. I'm running
the SMP kernel due to you suggesting it (nx feature). So both are running x86_64
SMP kernels.

Comment 5 Thomas J. Baker 2005-09-26 18:36:49 UTC
2.6.12-1.1456_FC4smp doesn't fix this problem. I went back to the first kernel
for fc4 and it didn't work either.

Comment 6 Dave Jones 2005-09-30 07:18:01 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.


Comment 7 Thomas J. Baker 2005-10-03 18:34:51 UTC
The problem still persists with 2.6.13-1.1526_FC4. I even checked on a 32bit
system and it's there too. So I have three systems with SoundBlaster Audigys and
they all don't seem to have input elements, an intel ia32e, and amd64, and an
intel ia32. All systems are running the SMP kernel, if that matters.

Comment 8 Thomas J. Baker 2005-10-05 18:26:18 UTC
This mysteriously just started working. I noticed after booting to the new
kernel the first time, my alsa settings got reset. Maybe after a second reboot
things started working better. I still don't have a capture tab on
gnome-volume-control but at least alasmixer allows sound input.

Comment 9 Dave Jones 2005-11-10 20:26:25 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.

Comment 10 Thomas J. Baker 2005-11-11 21:39:25 UTC
Still no capture tag on gnome-volume-control.

Comment 11 Nathan G. Grennan 2006-01-17 16:43:06 UTC
I am closing this. It has been working for me for a while.

Note You need to log in before you can comment on or make changes to this bug.