Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155070 - Only with OS update, ATI driver fails in supporting Rage XL, X cannot be started
Summary: Only with OS update, ATI driver fails in supporting Rage XL, X cannot be started
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 22:43 UTC by Magdalena Glinkowski
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 18:50:00 UTC


Attachments (Terms of Use)
Xorg.0.log: File shows ATI driver being unloaded and, associated message/reason. (deleted)
2005-04-15 22:43 UTC, Magdalena Glinkowski
no flags Details
Xorg.0.log (deleted)
2005-04-20 17:34 UTC, Magdalena Glinkowski
no flags Details
xorg.conf (deleted)
2005-04-20 17:39 UTC, Magdalena Glinkowski
no flags Details
xorg.conf (deleted)
2005-04-20 17:39 UTC, Magdalena Glinkowski
no flags Details

Description Magdalena Glinkowski 2005-04-15 22:43:43 UTC
Description of problem:

For qualification testing of Rhel4 U1 Beta on Intel server platforms, tried 
installing Rhel4 U1 IA64 Beta on Tiger 2 and Tiger 4, and X fails to start. 
Text-based install is successful. Xorg.0.log states the ATI driver is loaded, 
adapter/driver support issue is encountered and the driver is unloaded (see 
Additional Information). 

After installing, tried symlinking X11R6 to the X11R6 of RHEL4 (no update, 
which uses previous version of X) mounted on the same machine and X starts no 
problem - module is 6.5.6 in both cases but X release is different and failure 
occurs on X release 6.8.2 but not on X release 6.8.1. This issue doesn't occur 
on Tiger with RHEL4 no update.

Video card: VGA Compatible controller: ATI Technologies Inc Rage XL (rev 27)

ATI driver is unloaded after this message 
(for more activity see Additional Information):

"ATI(0): Adapters found to be in VGA mode on server entry are not supported by 
the MMIO-only version of this driver."

Version-Release number of selected component (if applicable):

How reproducible:

Every time.

Steps to Reproduce:

1. Acquire IA64 platform (Tiger2, or Tiger4) 
2. Begin install of RHEL4 U1 
3. Observe Anaconda trying to start X 

  
Actual results:

X cannot be started. (ati driver is loaded, says the driver doesn't support 
the video adapter, and is unloaded according to Xorg.0.log).

Expected results:

X starts.

Additional info:

Excerpt from xorg.conf:

Section "Device"
        Identified  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Mach64"

Excerpts from Xorg.0.log:

"(II) LoadModule: "ati"
(II) Loading /usr/X11R6/lib/modules/drivers/ati_drv.o
(II) Module ati: vendor="X.Org Foundation"
	compiled for 6.8.2, module version = 6.5.6
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 0.7"

"(II) ATI: ATI driver (version 6.5.6) for chipset: ati"

"(II) Primary Device is: PCI 01:01:0
(II) ATI:  Candidate "Device" section "Videocard0".
(II) ATI:  Shared PCI/AGP Mach64 in slot 1:1:0 detected.
(II) ATI:  Shared PCI/AGP Mach64 in slot 1:1:0 assigned to active "Device" 
section "Videocard0".
(II) Loading sub module "atimisc"
(II) LoadModule: "atimisc"
(II) Loading /usr/X11R6/lib/modules/drivers/atimisc_drv.o
(II) Module atimisc: vendor="X.Org Foundation"
	compiled for 6.8.2, module version = 6.5.6
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 0.7"

"(==) ATI(0): Chipset:  "ati".
(**) ATI(0): Depth 16, (--) framebuffer bpp 16
(EE) ATI(0): Adapters found to be in VGA mode on server entry are not 
supported by the MMIO-only version of this driver.
(II) UnloadModule: "ati"
(II) UnloadModule: "atimisc"
(II) Unloading /usr/X11R6/lib/modules/drivers/atimisc_drv.o
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found"

Comment 1 Magdalena Glinkowski 2005-04-15 22:43:43 UTC
Created attachment 113262 [details]
Xorg.0.log: File shows ATI driver being unloaded and, associated message/reason.

Comment 2 Mike A. Harris 2005-04-20 16:30:31 UTC
Please attach the X server log file and config file to the report as
individual uncompressed file attachments using the bugzilla file attachment
feature.

Comment 3 Magdalena Glinkowski 2005-04-20 17:34:57 UTC
Created attachment 113421 [details]
Xorg.0.log

Comment 4 Magdalena Glinkowski 2005-04-20 17:39:02 UTC
Created attachment 113422 [details]
xorg.conf

Comment 5 Magdalena Glinkowski 2005-04-20 17:39:07 UTC
Created attachment 113423 [details]
xorg.conf

Comment 6 Rob Landry 2005-04-25 18:50:00 UTC
Closing this one as dup. to maintain it linkage in other issue. Future updates
will come through issue-tracker #70085

*** This bug has been marked as a duplicate of 155609 ***


Note You need to log in before you can comment on or make changes to this bug.