Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155052 - Unable to create a new service
Summary: Unable to create a new service
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 20:47 UTC by Corey Marthaler
Modified: 2009-04-16 20:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 21:40:05 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-04-15 20:47:14 UTC
Description of problem:
This is a regression from the last build


Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 1319, in
on_svc_add_ok
    self.service_controller.prep_service_panel(service)
  File "/usr/share/system-config-cluster/ServiceController.py", line 259, in
prep_service_panel
    self.prep_service_tree()
  File "/usr/share/system-config-cluster/ServiceController.py", line 264, in
prep_service_tree
    treemodel.clear()
AttributeError: 'NoneType' object has no attribute 'clear'


Version-Release number of selected component (if applicable):
system-config-cluster-0.9.33-1.0.noarch.rpm

Comment 1 Jim Parsons 2005-04-25 21:00:10 UTC
Fixed in 0.9.34-1.0

Comment 2 Corey Marthaler 2005-04-26 16:03:56 UTC
fix verified in 0.9.36.

Comment 3 Corey Marthaler 2005-04-28 22:45:55 UTC
Rgression from version 42:

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 1351, in
on_svc_add_ok
    self.service_controller.prep_service_panel(service)
  File "/usr/share/system-config-cluster/ServiceController.py", line 259, in
prep_service_panel
    self.prep_service_tree()
  File "/usr/share/system-config-cluster/ServiceController.py", line 264, in
prep_service_tree
    treemodel.clear()
AttributeError: 'NoneType' object has no attribute 'clear'


Comment 4 Corey Marthaler 2005-04-29 20:54:59 UTC
this has been fixed in -44.

Comment 5 Corey Marthaler 2005-05-20 19:47:25 UTC
back again in 54...

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 1382, in
on_svc_add_ok
    self.service_controller.prep_service_panel(service)
  File "/usr/share/system-config-cluster/ServiceController.py", line 273, in
prep_service_panel
    self.prep_service_tree()
  File "/usr/share/system-config-cluster/ServiceController.py", line 278, in
prep_service_tree
    treemodel.clear()
AttributeError: 'NoneType' object has no attribute 'clear'


Comment 6 Jim Parsons 2005-05-23 17:00:13 UTC
Arghhh! This bug is because the delete-event is not being handled when the
dialog is 'X'ed closed. Fixed in 0.9.55-1.0

Please try and notice and record when clicking the dialog close 'X' is part of
the steps to reproduce. 

Comment 7 Corey Marthaler 2005-05-24 21:40:05 UTC
fix verified.


Note You need to log in before you can comment on or make changes to this bug.