Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155043 - unable to boot, when 2 volume groups in same discs
Summary: unable to boot, when 2 volume groups in same discs
Keywords:
Status: CLOSED DUPLICATE of bug 147361
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 20:19 UTC by Jussi Mikkola
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-01 15:19:36 UTC


Attachments (Terms of Use)

Description Jussi Mikkola 2005-04-15 20:19:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
I have an AMD64 that is run on a i386 version of FC4test2. It has nforce3 chipset and 2 sata disks. What I wanted to do is boot raid1 on primary + home and system on raid1 + tmp + not extra raid0 disk on lvm. I can configure, but when I start the computer, I get errors on e2fsck on the raid0 partitions. 

the disks are in the form, first boot, then raid1 then raid0.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC4
2. create partitions
3. boot the computer
  

Actual Results:  I end up in having errors on boot, and on a prompt asking for root password to fix the errors

Expected Results:  normal boot. This happens, if I configure boot partition and raid1 in 1 volume group with all volumes.

Additional info:

When I changed the raid0 to raid1, it did not help, when I still had the to LVMs on the same disks. Don't know, if adding disks would affect.

Comment 2 Alasdair Kergon 2005-05-04 13:39:39 UTC
Sorry but I can't parse your "What I wanted to do" sentence.

Can you split it up to show exactly what your configuration is?

Comment 3 Jussi Mikkola 2005-05-04 13:50:21 UTC
Hi, sorry, I don't remember any longer exactly, but here is the basic idea...

I have 2*200G sata disks. I want to have /boot raid 1 100M + 100G raid 1 + 200G
raid 0. And for all others than /boot, LVM.

I can create them during install, but when booting, it does not work.

Comment 4 Alasdair Kergon 2006-02-01 15:19:36 UTC
Guessing this is either similar to bug 147361, or else some problem with the
raid + dm in the initscripts that got fixed some time ago.

*** This bug has been marked as a duplicate of 147361 ***


Note You need to log in before you can comment on or make changes to this bug.