Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155040 - Can't build kernel with non 4K stacks
Summary: Can't build kernel with non 4K stacks
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 20:00 UTC by Ed
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 21:20:47 UTC


Attachments (Terms of Use)

Description Ed 2005-04-15 20:00:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
If you deselect the kernel hacking/4K stack kernel option when building a kernel it fails with the following error message

arch/i386/kernel/built-in.o(.init.text+0x1a47): In function `init_IRQ':
arch/i386/kernel/i8259.c:429: undefined reference to `irq_ctx_init'
arch/i386/kernel/built-in.o(.init.text+0x1a5e):arch/i386/kernel/i8259.c:429: undefined reference to `irq_ctx_init'
make: *** [.tmp_vmlinux1] Error 1

I demonstrated this by taking the kernel config from /boot and building it successfully. Then I did make xconfig and deselected the 4k stack option and got the above failure.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. see above description
2.
3.
  

Actual Results:  the error message above

Expected Results:  The kernel should have built correctly or information should have been present during configuration explaining how to avoid the problem

Additional info:

I am aware of your contemptuos dustbin classification in 'bug' 126342. This is clearly a problem redhat have introduced and I have gone to some effort to provide a clear and simple demonstration of *your* problem.

This roblem amtters to me as I have to use 3rd party modem drivers which require larger stacks. The 2.6.11 kernel is unusable by me as I cannot use it in conjunction with these drivers.

Comment 1 Dave Jones 2005-04-15 21:13:26 UTC
Rik, this seems to be caused by something in the Xen patches.


Comment 2 Dave Jones 2005-04-15 21:20:47 UTC
actually, it doesnt, bad grep on my part.
this looks to be broken upstream.


*** This bug has been marked as a duplicate of 126342 ***

Comment 3 Arjan van de Ven 2005-04-16 07:36:01 UTC
as for modem drivers... you are aware of the slmodem userspace modem stack right ?


Note You need to log in before you can comment on or make changes to this bug.