Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155036 - Kernel panic from appletalk
Summary: Kernel panic from appletalk
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL: http://pastebin.arslinux.com/1676
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 19:45 UTC by Ron Sokoloski
Modified: 2015-01-04 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 21:11:02 UTC


Attachments (Terms of Use)

Description Ron Sokoloski 2005-04-15 19:45:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
Downlevel clients on this server seem to be able to cause random kernel panics - see the console capture in the above URL. I have an identical server in another location running FC3 that doesn't exhibit this behaviour, I believe due to the abcense of any Mac OS clients lower that OS8.5. This location has one or 2 Mac OS clients in the 8.1 range.

I am using a Netatalk 2.0 RPM made for ClarkConnect, but since that product is based on FC3 it should run fine - in fact , I have 2 other servers in production with this RPM. I think the kernel should be more resilient than this anyway - a driver issue like this shouldn't take out the whole kernel.

Version-Release number of selected component (if applicable):
kernel--2.6.10-1.770_FC3smp

How reproducible:
Sometimes

Steps to Reproduce:
1.Install this RPM on an updated FC3 server: http://public.planetmirror.com/pub/clarkconnect/clarkconnect-3.0/other/netatalk-2.0.2-1.i386.rpm
2. Connect a Mac OS 8.x client to the resulting AFP share
3. Keep the share open on the desktop
  

Actual Results:  Kernel paniced, results logged to serial console

Expected Results:  Kernel should have kept running, even if it shut down AppleTalk

Additional info:

Comment 1 Dave Jones 2005-04-15 21:11:02 UTC
you'll probably get this fixed quicker by reporting it upstream to its
maintainer acme@conectiva.com.br

Appletalk gets zero testing at Red Hat, and is enabled in Fedora kernels as a
convenience to users only. We basically rely on upstream being in good enough
shape to continue to do this.


Comment 2 Ron Sokoloski 2005-04-17 19:18:09 UTC
I've forwarded this bug to the e-mail address given to me above.

Thanks.

Ron


Note You need to log in before you can comment on or make changes to this bug.