Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1550160 - webpack assets build are development vs production [NEEDINFO]
Summary: webpack assets build are development vs production
Keywords:
Status: CLOSED DUPLICATE of bug 1511503
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-28 16:38 UTC by Ohad Levy
Modified: 2019-01-25 17:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-25 17:46:26 UTC
mhulan: needinfo? (ohadlevy)


Attachments (Terms of Use)

Description Ohad Levy 2018-02-28 16:38:13 UTC
Description of problem:

The webpack based assets that are shipped via satellite 6.3.0 are development based and not production based.

when building the assets, make sure NODE_ENV=production environment variable is used.

Comment 1 Eric Helms 2018-02-28 17:34:38 UTC
This is exactly the problem hit by https://bugzilla.redhat.com/show_bug.cgi?id=1511503 so I'd argue we close this as a duplicate and work from the other one. The fix is quite simple in our build tooling.

Comment 2 Ohad Levy 2018-02-28 17:57:23 UTC
I'm not sure, as the original bug had an issue with caching, not just the content itself.

Comment 3 Marek Hulan 2018-03-01 08:57:13 UTC
Could you please provide more information, namely how to verify this? Also is this a packaging problem of really a WebUI issue?

Comment 5 Mike McCune 2018-03-17 20:32:11 UTC
This looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1511503

I'd vote we close this out when the above is resolved if that is indeed the case

Comment 7 Mike McCune 2019-01-25 17:46:26 UTC
closing this out, feel free to reopen if this is premature.

*** This bug has been marked as a duplicate of bug 1511503 ***


Note You need to log in before you can comment on or make changes to this bug.