Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155003 - up2date appears to bomb with attribute error when run from command line - no feedback in the GUI version
Summary: up2date appears to bomb with attribute error when run from command line - no ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 15:33 UTC by Joe
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-05 16:26:46 UTC


Attachments (Terms of Use)

Description Joe 2005-04-15 15:33:25 UTC
Description of problem:
After initialy working correctly several times up2date suddenly stopped working.
In GUI mode up2date will retreive headers and display the list of packages to
update, but when package/s is/are selected, nothing happens.  The forward button
 remains greyed out with only the back and cancel buttons active.

When executing up2date on the command line it ends with an attribute error from
 RpmmdSolveDep.  Command line output is pasted into the "actual results" section
below.

Version-Release number of selected component (if applicable):

Hmmm, maybe another bug, when running up2date --version, I get a nice pop up
window with no version information anywhere in the window.

RPM -q reports ==> up2date-4.4.14-2

How reproducible:

Happens every time I run up2date. 

Steps to Reproduce:
1.Either click on the RH Alert notification icon or run up2date from a command line.
2.
3.
  
Actual results:

[joed@localhost ~]$ up2date -u --nosig
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-rawhide
using mirror: http://sunsite.mff.cuni.cz/pub/fedora/development/x86_64/

Fetching Obsoletes list for channel: development...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
oprofile                                0.8.2          4                 x86_64
pam                                     0.79           5                 i386
pam                                     0.79           5                 x86_64
pam-devel                               0.79           5                 x86_64
perl-Net-DNS                            0.49           2                 x86_64
policycoreutils                         1.23.6         1                 x86_64
poppler                                 0.2.0          2                 x86_64
portmap                                 4.0            65                x86_64
qt                                      3.3.4          11                i386
qt                                      3.3.4          11                x86_64
qt-devel                                3.3.4          11                x86_64
quota                                   3.12           6                 x86_64
redhat-artwork                          0.122          2                 i386
redhat-artwork                          0.122          2                 x86_64
redhat-menus                            3.8            1                 noarch
selinux-policy-targeted                 1.23.11        1                 noarch
sendmail                                8.13.4         1                 x86_64
spamassassin                            3.0.2          8.fc4             x86_64
sqlite                                  3.1.2          3                 x86_64
sqlite-devel                            3.1.2          3                 x86_64
sudo                                    1.6.8p8        1                 x86_64
system-config-lvm                       0.9.25         1.0               noarch
system-config-securitylevel             1.5.7          1                 x86_64
system-config-securitylevel-tui         1.5.7          1                 x86_64
unix2dos                                2.2            26                x86_64
usbutils                                0.70           1                 x86_64
util-linux                              2.12p          7                 x86_64
vim-common                              6.3.071        1                 x86_64
vim-enhanced                            6.3.071        1                 x86_64
vim-minimal                             6.3.071        1                 x86_64
vixie-cron                              4.1            33                x86_64
xchat                                   2.4.3          2                 x86_64
xinitrc                                 4.0.18         1                 noarch
xorg-x11                                6.8.2          22                x86_64
xorg-x11-Mesa-libGL                     6.8.2          22                i386
xorg-x11-Mesa-libGL                     6.8.2          22                x86_64
xorg-x11-Mesa-libGLU                    6.8.2          22                i386
xorg-x11-Mesa-libGLU                    6.8.2          22                x86_64
xorg-x11-deprecated-libs                6.8.2          22                x86_64
xorg-x11-devel                          6.8.2          22                x86_64
xorg-x11-font-utils                     6.8.2          22                x86_64
xorg-x11-libs                           6.8.2          22                i386
xorg-x11-libs                           6.8.2          22                x86_64
xorg-x11-tools                          6.8.2          22                x86_64
xorg-x11-twm                            6.8.2          22                x86_64
xorg-x11-xauth                          6.8.2          22                x86_64
xorg-x11-xdm                            6.8.2          22                x86_64
xorg-x11-xfs                            6.8.2          22                x86_64
yp-tools                                2.8            8                 x86_64
zlib                                    1.2.2.2        3                 i386
zlib                                    1.2.2.2        3                 x86_64
zlib-devel                              1.2.2.2        3                 x86_64


Testing package set / solving RPM inter-dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1250, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1137, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 78, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 163, in __dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 722, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 616, in process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 323, in __dependencies
   msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 97, in solveDep
    msgCallback = msgCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
132, in solveDep
    msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/rpmmdRepo.py", line 60, in
getSolutions
    provs = self.pkgSack.searchProvides(unknown)
AttributeError: RpmmdSolveDep instance has no attribute 'pkgSack'
[joed@localhost ~]$


Expected results:

Either complete update of selected packages, or display an error message in the
GUI panel.
 
Additional info:

Comment 1 Sebastian Mendel 2005-04-19 11:26:24 UTC
also see Bug #154904
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154904

Comment 2 r c 2005-04-19 16:58:10 UTC
I am getting this same error after upgrading from up2date...9 to ...14.  I
believe the update failed as there was an error message about a script failure
at the end of the install, nevertheless it was marked complete.

Comment 3 John Thacker 2006-10-29 20:25:52 UTC
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.

Comment 4 John Thacker 2006-11-05 16:26:46 UTC
Closing per previous message.


Note You need to log in before you can comment on or make changes to this bug.