Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155000 - mediacheck fails on Dell Latitude C800
Summary: mediacheck fails on Dell Latitude C800
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 15:10 UTC by Frank Swasey
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 18:06:41 UTC


Attachments (Terms of Use)

Description Frank Swasey 2005-04-15 15:10:38 UTC
Description of problem:

mediacheck of all four i386 binary installation CD's fails

Version-Release number of selected component (if applicable):

FC4T2 i386 Binary ISO's

How reproducible:

Burn the ISO's to media (I am using CDRW personally)
Use readcd/sha1sum to VERIFY they burned correctly (SHA1's match)
Boot with the media and allow it to run the mediacheck 

Steps to Reproduce:
1.
2.
3.
  
Actual results:

All four will issue a status of FAILED

Expected results:

Expect them to pass -- since the readcd output sha1sum matches the original ISO

Additional info:

Comment 1 Frank Swasey 2005-04-15 15:12:27 UTC
I have posted this against the kernel because I see that is where other problems
reported against mediacheck have been posted.  I am refering to issues 135795
and 150186 against RC3T3 and WS4 respectively.

I do not know (nor do I care to waste the media to see) if using CDR's instead
of CDRW's makes any difference.

Comment 2 Dave Jones 2005-04-15 20:33:52 UTC
does the problem go away if you boot with ide=nodma ?


Comment 3 Frank Swasey 2005-04-16 00:32:32 UTC
Booting off CD (disc1) and entering "linux ide=nodma" and then doing the
mediacheck, the check still fails.

Comment 4 Dan Hollis 2005-04-22 19:20:32 UTC
can you try disabling readahead on the cd device? eg:

hdparm -a 0 /dev/cdrom

Comment 5 Frank Swasey 2005-04-22 21:36:44 UTC
I do not see any way of issuing "hdparm -a 0 /dev/cdrom" having booted from the
install media.  Alternatively, I do not see any way of running the media check
once I have the OS installed.

I did try "linux mediacheck nocddma", but it still fails.

I have also performed a "readcd dev=/dev/cdrom f=disc1.iso" (on the same laptop
with the same drive and the same disk that fails the mediacheck) and it has the
same sha1sum that the SHA1SUM file says belongs to FC4-test2-i386-disc1.iso.

I'm willing to try just about anything here... other suggestions?

Comment 6 Frank Swasey 2005-05-19 15:14:30 UTC
The mediacheck is working with the new FC4T3 i386 CD-RW's I have burned.

Any idea what fixed it?


Comment 7 Dave Jones 2005-05-21 07:11:50 UTC
Not sure. There are lots of IDE layer improvements in the kernel since test3.
The installer folks also changed the way mediacheck works. It now checksums
smaller segments instead of the one whole image. It might just be a change in
the access patterns on the CD that have made the bug more difficult to reproduce.


Comment 8 Dan Hollis 2005-05-30 08:58:08 UTC
FC4T3 mediachecks seems to work for me now as well. FC3 and such were definitely
broken.

Comment 9 Dave Jones 2005-06-27 23:30:12 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Comment 10 Frank Swasey 2005-06-28 10:53:02 UTC
mediacheck works on fc4 final release for me.


Note You need to log in before you can comment on or make changes to this bug.