Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154994 - rhn-tab-directory must be updated appropriately for java navigation
Summary: rhn-tab-directory must be updated appropriately for java navigation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D
Version: RHN Devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ken Ganong
QA Contact: Vlady Zlatkin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 14:43 UTC by Ken Ganong
Modified: 2007-04-18 17:23 UTC (History)
1 user (show)

Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-31 20:54:47 UTC


Attachments (Terms of Use)
Screenshot (deleted)
2005-04-29 15:25 UTC, Ken Ganong
no flags Details

Description Ken Ganong 2005-04-15 14:43:56 UTC
Description of problem:
Occassionally in java the left nav when browsing in a tab converts to the "Your
RHN" left nav.

How reproducible:
Browsing pages under a tab sometimes causes this to happen, though I haven't
been able to make it happen consistently through normal browsing.

Steps to Reproduce:
1. Click on a tab other than the Users tab.
2. Find out a user's id in your org.
2. type in the url for rhn/users/UserPreferences.do?uid=XXXX  where XXX = a
user's id in your org.
  
Actual results:
Your RHN left nav appears on the page.

Expected results:
Users left nav appears on the page.

Comment 1 Ken Ganong 2005-04-29 15:25:26 UTC
Created attachment 113850 [details]
Screenshot

Inappropriate left nav

Comment 2 Ken Ganong 2005-04-29 19:48:20 UTC
So the problem boiled down to a xml mistake.
was:
<rhn-tab-directory>/network/users</rhn-tab-directory>
now:
<rhn-tab-directory>/rhn/users</rhn-tab-directory>

For every tab directory we should have this correct so that our NavTreeIndex can
activate the correct tab.

Changing the summary of this bug and aligning to 400

Comment 3 Ken Ganong 2005-06-24 20:49:40 UTC
TEST PLAN
example case:
1. Click on a tab other than the Users tab.
2. Find out a user's id in your org.
3. type in the url for rhn/users/UserPreferences.do?uid=XXXX  where XXX = a
user's id in your org.
4. Verify correct left nav

basically, copy and paste urls from a different site context instead of using
the sitenavs to get to places and verify that the correct nav structure and
highlighting is rendered.

Comment 4 Vlady Zlatkin 2005-07-06 21:23:26 UTC
so should i see this: 

html/nav/sitenav-authenticated.xml:     
<rhn-tab-directory>/network/users</rhn-tab-directory>

Comment 5 Ken Ganong 2005-07-06 21:50:03 UTC
Here is a list of urls that I have seen problems with in the past.

The typical:
/rhn/users/UserPreferences.do?uid=XXXX

For Actions that have package/patch/patchset installs or removals.
/rhn/schedule/PackageList.do?aid=XXXX

Pages where the entire tree of active nodes is hybrid perl and java nodes.
/network/errata/manage/packages/index.pxt?eid=XXXX
any /network/errata/manage/*.pxt
/network/systems/details/channels.pxt?sid=XXXX
any /network/systems/details/*.pxt

Pages whose urls do not appear on node listing because they are deep within a
use path.
/rhn/users/EditAddress.do?type=M&uid=XXXX
/rhn/systems/details/packages/profiles/CompareProfiles.do?sid=XXXX&prid=XXXX

Comment 6 Vlady Zlatkin 2005-07-07 20:03:17 UTC
prod ready


Note You need to log in before you can comment on or make changes to this bug.