Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154984 - Sound Blaster Audigy 2 Value audio does not work
Summary: Sound Blaster Audigy 2 Value audio does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard: kernelQA
Depends On:
Blocks: 181409
TreeView+ depends on / blocked
 
Reported: 2005-04-15 12:05 UTC by Jussi Silvennoinen
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHSA-2006-0575
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-10 21:03:23 UTC


Attachments (Terms of Use)
Adds support for SB Audigy 2 Value (deleted)
2005-04-15 12:07 UTC, Jussi Silvennoinen
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2006:0575 normal SHIPPED_LIVE Important: Updated kernel packages available for Red Hat Enterprise Linux 4 Update 4 2006-08-10 04:00:00 UTC

Description Jussi Silvennoinen 2005-04-15 12:05:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
SB Audigy 2 Value is not found by kudzu or system-config-soundcard.
Support was added in Alsa 1.08

http://us.creative.com/products/product.asp?category=1&subcategory=204&product=10653


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.0.3.EL

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 to a box with SB Audigy 2 Value
2. Run system-config-soundcard
3. No supported soundcards found
  

Actual Results:  No supported soundcards found.


Expected Results:  Supported soundcard found during bootup by kudzu and relevant configuration added.


Additional info:

Comment 1 Jussi Silvennoinen 2005-04-15 12:07:12 UTC
Created attachment 113219 [details]
Adds support for SB Audigy 2 Value

Adds support for SB Audigy 2 Value

Comment 4 Suzanne Hillman 2005-04-18 13:35:59 UTC
Internal RFE bug #155240 entered; will be considered for future releases.

Comment 5 John W. Linville 2005-11-08 21:10:48 UTC
Test kernels w/ above patch available here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
Please give them a try to verify that everything works, and post the 
results...thanks! 

Comment 6 Jussi Silvennoinen 2005-11-09 06:57:45 UTC
Works.

I've been running various recompiled RHEL4 kernel's with the attached patch
since April without problems.


Comment 8 Jussi Silvennoinen 2006-03-13 10:23:13 UTC
I guess it's not in U3?


Comment 9 John W. Linville 2006-03-13 16:46:11 UTC
No, it missed the U3 cut-off back in November.  But, it should be in U4. 

Comment 11 Roderick Johnstone 2006-03-31 12:18:38 UTC
I have one of these cards and have been unable to get it working with the
latest (as of yesterday) jwltest kernel 2.6.9-34.7.EL.jwltest.128smp on x86_64
in U2.

linux> lspci | grep Multi
03:09.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value

The card seems to be detected fine (eg lots of relevant stuff in /proc/asound)
and the snd_emu10k1 module is loaded but there is no sound from the output.

I've been all through alsamixer and kmix and unmuted everything and turned every
volume up, but there is still no actual sound when issuing an aplay command. The
aplay command seems to somplete normally, not hanging or anything.

Is there anything apart from jwltest kernel thats needed to make this card work?

Comment 12 John W. Linville 2006-03-31 14:40:16 UTC
AFAIK, nothing special is required to make it work.  Have you tried all the 
jacks (speaker, headphone, etc)?  Is there sound on any of them? 
 
Please attach the output of running "sysreport"...thanks! 

Comment 13 Roderick Johnstone 2006-04-04 15:00:47 UTC
I've tried all the outputs, no sound anywhere.

Can I email you the output rather than post to the list please?

By the way, this is actually on Scientific Linux rather than genuine Redhat
Enterprise.


Comment 14 John W. Linville 2006-04-11 19:22:36 UTC
You can mark an attachment as private, if that is helpful.  If not, then email 
is fine with me.  But, I don't know if RH's mail server will accept anything 
that big... 

Comment 15 Jason Baron 2006-04-19 14:54:20 UTC
committed in stream U4 build 34.19. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/ However, there is a *serious* slab
corruption issue with this kernel, and thus it should not be released to
customers under any circumstances. I'll update this bug when the kernel is
stable again.


Comment 16 Jason Baron 2006-04-19 19:59:43 UTC
We've identified the corruption as specfic to x86-64 smp kernel builds 34.16 and
34.17. All other builds are safe for consumption.


Comment 19 Red Hat Bugzilla 2006-08-10 21:03:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0575.html



Note You need to log in before you can comment on or make changes to this bug.