Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154980 - Update to SDL-1.2.8-3 drops various symbols
Summary: Update to SDL-1.2.8-3 drops various symbols
Keywords:
Status: CLOSED DUPLICATE of bug 154771
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 10:25 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 12:16:28 UTC


Attachments (Terms of Use)

Description Ralf Ertzinger 2005-04-15 10:25:21 UTC
Description of problem:
Updating to SDL-1.2.8-3 causes mplayer (external package) to
spew errors about missing symbols:

undefined symbol: ConvertMMXpII32_16RGB565      (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertMMX    (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_16RGB565        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86    (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertMMXpII32_16BGR565      (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_16BGR565        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertMMXpII32_16RGB555      (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_16RGB555        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertMMXpII32_16BGR555      (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_16BGR555        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_24RGB888        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_24BGR888        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_32BGR888        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_32RGBA888       (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_32BGRA888       (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p16_16BGR565        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p16_16RGB555        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p16_16BGR555        (/usr/lib/libSDL-1.2.so.0)
undefined symbol: ConvertX86p32_8RGB332 (/usr/lib/libSDL-1.2.so.0)

Version-Release number of selected component (if applicable):
SDL-1.2.8-3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to SDL-1.2.8-3
2.
3.
  
Actual results:
Missing symbols that were exported in SDL-1.2.8-2

Expected results:
No ABI changes

Additional info:

Comment 1 Thomas Woerner 2005-04-15 12:16:28 UTC

*** This bug has been marked as a duplicate of 154771 ***


Note You need to log in before you can comment on or make changes to this bug.