Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154976 - "Administrator mode" button doesn't work in kcontrol
Summary: "Administrator mode" button doesn't work in kcontrol
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 09:06 UTC by Mary Ellen Foster
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 09:41:59 UTC


Attachments (Terms of Use)

Description Mary Ellen Foster 2005-04-15 09:06:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
On some of the KDE Control Centre modules, there's an "Administrator mode" button that lets you type in the root password and do some system-level configuration. In the latest Fedora KDE, it doesn't seem to work: I click the button, type the root password into the resulting dialogue box, wait a couple of seconds, and then it shows the initial KControl screen instead of the administrator-mode version of the module I was working in.

This happens at least with the "Login Manager" and "Font Installer" modules.

Version-Release number of selected component (if applicable):
kdebase-3.4.0-5

How reproducible:
Always

Steps to Reproduce:
1. Start KDE Control Centre
2. Choose "System Administration" - "Login Manager"
3. Press "Administrator mode"
4. Type root password into dialogue box
  

Actual Results:  It showed the "Welcome to the KDE Control Centre" screen again

Expected Results:  It should have shown me the "Login Manager" module in administrator mode

Additional info:

Comment 1 Ngo Than 2005-04-18 10:11:23 UTC
it's not reproduceable in latest rawhide. could you please do update to latest
rawhide and verify it please. Thanks

Comment 2 Mary Ellen Foster 2005-04-22 09:01:55 UTC
Still happens in latest rawhide ...

Comment 3 Ngo Than 2005-04-25 16:42:51 UTC
it's strange, i'm not able to reproduce it. Could you please try with a new user?

Comment 4 Mary Ellen Foster 2005-04-26 09:41:59 UTC
Yes, with a new user, it worked fine on the "login manager" tab. Popped up an
error message about "Unable to create /usr/share/apps/kdm/faces" (or something
very similar, I'm not in front of that computer now) but it worked. Weird. Sorry
for the false alarm.

Comment 5 Neil Grover 2005-04-27 07:14:39 UTC
don't know if this helps, but kcontrol was working fine for me (including the
administrator mode buttons).........until one time I did a "sudo kcontrol" from
the command line. After that, everytime i used kcontrol as a regular user the
administrator buttons did not work, it would just kick me back to the blue
colored screen with the links.


Note You need to log in before you can comment on or make changes to this bug.