Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154966 - Realtek ALC 880 onboard sound not detected
Summary: Realtek ALC 880 onboard sound not detected
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 05:19 UTC by David Kinzer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 11:12:41 UTC


Attachments (Terms of Use)

Description David Kinzer 2005-04-15 05:19:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
New HP m7060n Media Center PC. (Private ASUS motherboard with integrated sound.)
Install FC3 core (workstation config) from scratch.
Sound chip is not detected.
Core is "up2date"

From Specs sheet:
      Integrated Intel High Definition (TM) audio (Azalia) 

          o Realtek ALC 880 chipset
          o THX certification support
          o 8-channels for Full Dolby 5.1/6.1/7.1 surround sound support with Dolby Pro Logic IIx
          o Dolby 5.1


Version-Release number of selected component (if applicable):
alsa-lib-1.0.6-7.FC3

How reproducible:
Always

Steps to Reproduce:
1. Blow away Fedora Install
2. Install from FC3 DVD
3. Follow all prompts.
4. Kudzu detects 8802 chip on first boot, click "configure", Kudzu disappears.
5. /usr/bin/system-config-soundcard => "No Soundcards were detected."  

Actual Results:  Anaconda does not prompt for any sound card information during install.
Kudzu detects "new hardware" but "configure" just makes it go away.



Expected Results:  Ideally, sound system would be detected and configured and I could continue to be an ignorant newbie and just enjoy using Fedora instead of "the other OS" which works fine with the hardware.


Additional info:

I could not find anything similar enough using search facilities, this seems to be the stuff that experts ask for:
lspci -v excerpt:
02:04.2 Multimedia controller: Conexant: Unknown device 8802 (rev 05)
        Subsystem: ASUSTeK Computer Inc.: Unknown device 4823
        Flags: bus master, medium devsel, latency 64, IRQ 169
        Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [4c] Power Management version 2

lsmod excerpt:
cx8800                 34765  0
v4l1_compat            17605  1 cx8800
v4l2_common             9793  1 cx8800
cx88_blackbird         18501  0
cx8802                 14277  1 cx88_blackbird
cx88xx                 51797  3 cx8800,cx88_blackbird,cx8802
i2c_algo_bit           13001  1 cx88xx
video_buf              25413  4 cx8800,cx88_blackbird,cx8802,cx88xx
btcx_risc               8905  3 cx8800,cx8802,cx88xx
videodev               13633  3 cx8800,cx88_blackbird,cx88xx

Comment 1 Martin Stransky 2005-04-15 11:12:29 UTC
Current sound drivers in Linux don't support this hardware for sound
output. You can send your request directly to ALSA project,
www.alsa-project.org and people here can make driver for your sound card.

Comment 2 David Kinzer 2005-04-17 21:04:29 UTC
For future readers:

This board is supported in ALSA 1.0.9rc2.  

My sound system is now functional.

Thanks for your assistance.


Note You need to log in before you can comment on or make changes to this bug.